Android Nightly discussion thread


#401

not sure what you’re talking about… mame doesn’t need bios files it needs parent roms, they are just part of the romset


#402

I see some file called neogeo.zip . Some pepople say i need put this file into the content folder togther with the romfile?
I downloaded alot of the mame 0.78 roms .But found a lot of them just a black screen or not render correctly ? I am using android . Do you have some idea over this ? How can I get them to work? @radius


#403

Hello, having an issue with the nightlies. not sure what type of search terms to use to see if this had already been asked.

issue 1, when I load a PSX rom without any BIOS, the cores load the ROM fine. when I change directory to enable usage of factory BIOS RetroArch is unable to load the ROM. retro arch simply loads the factory BIOS.

issue 2, when changing state # for saving or loading this works and displays correctly. when saving or loading though display always shows loading or saving from state #0. saving and loading does happen from correct state #, but the display is incorrect at the bottom.

thanks for the hard work guys, RetroArch is amazing!


#404

Edit: Same mess-up as last time,I am on the GIT version. Still confused from the corrupt error rather than a signature mismatch error,but my problem was the same stupid one where I am on the GIT build and can’t install stable versions over it.

Edit 2: I just installed the 1.4.1 GIT from “2017-2-3” and touch still fails to work on Shield TV Pro (2015) within Retropad onscreen buttons despite the claim of fixing support for it. :frowning2: Why is RetroArch so unfair when it comes to wanting features to start working properly instead of staying non-functional? I would say its Android’s/Google’s fault for ditching the old touch method to begin with.


#405

What happened to Mame 0.139 core “Mame 2010” on Android? Using latest nightly it seems to be gone. I used the online core updater to try and find it.


#406

it hasn’t built ever. Maybe it was there when there was no buildbot but it hasn’t built on my watch.


#407

Shield TV and touch?? what are you talking about… there is no touch. It fixes touch on devices that have touch.


#408

Mouse input to make “touch” actions on Shield TV. On a much older OTA version,Retropad functioned properly while the menus were a little glitchy,and ever since Marshmallow,the touch input “via mouse taps/clicks” stopped working much like other MM devices across the board. After several OTA upgrades,Nougat was released for Shield TV,now along with itself and the RetroArch updates,the Retropad still doesn’t work due to one tiny dropped Android feature since MM.

So,whatever the input overlay does in Mupen64Plus AE (FZ Edition),it works on Shield TV while RetroArch’s input overlay method response is still non-existant. What’s the point of a beastly 4K60p-capable emulation Android machine existing when it can hardly access RetroArch due to missing touch/mouse input functionality which many other Android apps have? The controller for it even has mouse access in the right analog stick for crying out loud! :upside_down: (as I have stated long ago before,it was a nightmare just to get it working back on Lollipop when the new GUI was really buggy where no keys would work for navigating at all and touch worked enough to be frustrating because you couldn’t change various options without scroll being stuck,unable to map inputs for easier navigation and changing settings to actually start using it)


#409

What is the “staging” builds in the nighties? What’s it different from the normal builds?


#410

They are specifically for one person that has a prototype device. I asked the same thing yesterday


#411

Thanks man! I installed the normal version.


#412

Mupen64 cores fail to load except for the ParaLELI version. Everything else works fine. On the Google Play version, none of the N64 cores work. N64 cores are always the ones that have issues it seems. Galaxy tab 4.4.2


#413

Try editing the core settings text by deleting all of the N64 core options so it reverts to defaults,that usually fixes the N64 cores for me.

Also,this topic took ages to load thanks to the inferior page-less design making it load ALL 400+ comments. If that part can be customized for taking the last ten or so latest comments as the only part that loads and displays first,then that would help.

I really hate that design choice of not having pages. For example,it’s so much harder to search on Google Play when you don’t have pages and you are forced to re-click the “more…” option to get back to where you left off,sometimes being several clicks to load more again,and even then,it cuts off results short to a very low limit instead of allowing all results to appear. It also made the Play Store site a LOT slower since they changed it,any low-end device (Android or PC) would struggle to navigate its performance hogging re-design. It still even lags a bit on my Shield TV (OTA 5.0.2 Nougat) within a browser when other sites are quite fast.


#414

When I said the cores failed to load, I meant that it legitimately fails to load. Retroarch apparently treats them as non-existent. Whenever I try to load the Mupen64 core, the main menu title still says “(No Core)”. Deleting the core options do nothing, since I could only get ParaLLEI to work, and only shows ParaLLEI options. Do I need to manually download the cores or something, because I’m stumped?

On your other topic though, you can actually jump to any comment you want without loading all 400+ comments. On that blue button indicating comment number, you can press it and another button will show up called “jump to”, and the rest is self-explanatory.


#415

I think compiler requirements were bumped for mupen… so yeah probably it won’t work in < 5.0


#416

Oh man, now that is a huge inconvenience. Is the N64 that complex or hard to deal with compared to others?


#417

Why don’t you use parallel n64 core? It’s the core you were probably using before the renaming


#418

Well I do use Parallel now since it runs. I didn’t know it was renamed and changed, so thanks for the link.


#419

Hi!

Do the Android builds of PicoDrive and PCSX ReARMed work for someone or are they currently broken?


#420

For some reason GPSP (GBA) and Picodrive cores are crashing for me, PCSX Rearmed is working fine, so does all others I tried with the latest nighly.