Anyone get Atari 5200 working under RetroArch?

awaiting better integration of this to in retroarch/libretro… :slight_smile:

1 Like

The Atari 800 core works?

This golden nugget of info may have just made my night. One of those few systems I haven’t gotten working.

The closest thing in the MAME/“MESS” core I got working was the GX4000 but the screen was all tiny as hell. lol

Ho, i forgot to add the A5200 key :slight_smile: this version should handle them.

for the few test i have done , i’m not familiar with A5200 as i use this core for a800 games , so when i start an 5200 game (in my case QIX (1982) (Atari) [b2].bin a 32K cartridge) screen is black , i have to hit a key ,then menu ask me for the format of cartridge , if i choose 2chip 16k 5200 cartridge then the title screen of the game appear . i have to hit F4 to start game.

yes it works, but like all other port I did , It is considered rough and wip. But it does not bother me, at least I quiet with the complaints of the users :slight_smile:

For Gx4000 i use libretro-arnold port , not mame.

BTW QIX is a good game but i prefer the arcade version of Volfied

“Libretro-arnold”? I’ve never seen that core.

Man I am getting all sorts of greatness from this thread.

Didn’t work for me. After going from Emulation Station, I picked QIX… started, black screen, hit a keyboard button, got a beep, then after another button, I got the Emulation Window (giving me all the options to select), Selected 2 chip 16K 5200 cart, backed out, selected back to emulator and it gives me a EMULATION HAULTED and the message that I needed an official Atari system/OS to run…

Sigh… Would this be how run each game ?

finally spent the time to test @r-type atari800 core. here are some quick notes.

  1. Load any atari800 or 5200 with Atari800 3.1.0 core. does not matter if your game does not work, we just need to be able to enter the menu.
  2. when game is loaded, press F1 (this is quick-menu, just cancel or press F1 again or whichever is your quickmenu hotkey) - this will show you Atari800 menu(use joystick/gamepad to navigate. On Xbox 360 controller. button B is OK while Y is back. if nothing is working, go to quick menu-Controls and choose ATARI Joystick for User 1 Device Type
  3. While im Menu, goto Emulator Configuration -> System ROM Settings then Find ROM images in a directory
  4. Locate your atari5200 and atari800 bios roms. these roms have to be uncompressed. -Atari400/800 - atariosb.rom -XL/XE - atarixl.rom -Basic - ataribas.rom -5200 - 5200.rom Once rom folders are set, press SPACEBAR to save location. 5.go back to Emulator Settings and then choose Save Configuration file.
  5. goto quick menu and close content.
  6. By this time, you can now play games. do note that the games has to be extracted and uncompressed too. You can use Load Content method in Retroarch. if you load a compressed rom, your game will not play and you are stuck in Self Test mode.
  7. When you do load a game, and see only black screen, just press Enter or OK on your gamepad.

BUG-after initial configuration, program seems not able to go to previous folder […], so using the Run Atari from menu is not usuable.

Tested on Windows 10 x64

1 Like

Nice, you got it working… I had -0- luck on Windows 7 x64…(wellthe 800 emulator ran, the menu came up but, could not load a 5200 game)

The question I have… is it possible to save the settings ?

At this point, I could care less about the Atari 800… I want to play 5200 and I want to play the 5200 solid with my Xbox 360 controller(there is enough buttons for everything besides the keypad).

Getting kind of upset with every option including the Atari 800 not working. I gave this one a shot…

And it worked…but, 1/2 the games don’t play. And of course, the ONE game I wanted to play QIX, didn’t play… Is there a better core to use with this (now that the BIOS is in the right place)?

So, most games that have the blinking Atari logo on startup (Atari games) they kind of lock up there. Other games that do play, get a min or 2 into a game then lock up (system not locked up, the GAME locked up).

I used mame_libretro.dll (one I found and dropped in)

after alot of manual manipulation, was able to run Qix

but there was no way to start the game. probably joysticks not detected or routed?

F4 for start that game. If you have the very last version i uploaded above witch handle a5200 input. No manipulation to load or start it

As stated previously i use for qix (32k version rom) from the a5200 merged goodset.

why i said manual manipulation? coz for some reasons i cannot browse previous folders. stuck at retroarch folder where .atari800.cfg is located, so roms should be there including bios. now in order to load up qix.bin, have to use Run Atari Program and load the uncompress qix.bin as Two chip 16KB 5200 cartridge in order to load. you say press F4 to play? here what happens when you press F4 when the game is loaded.

Have you the last version from here? Else f4 two time ?

I have a hard time understanding how this core works.

I just get a black screen. If i press F1 it just shows RetroArch menu. If i press F4 it says “core does not support save states”. Nothing else happens though and there is no “atari800 menu”. I press all these buttons multiple times.

What am i doing wrong?

Thanks @r-type for the work here. I still could not get it to work.

Anyway about it, it’s not what I am looking for. I wanted a true plugin that I could kick off a game from Emulation Station with just a click.

Is there a way to get this to focus more on the 5200 than the 800XL, so it could be a piugin more for the 5200 ?

its easier to run 5200 in mame

Ok i cant help here more.

I only answer to your topic that you can get a5200 roms working also with atari800 than traditional mess. No more.

The solution for your question is to ask dev to port an a5200 emulator.

@wertz it s your point of view. Note im also comfortable with mame/mess as i port all the libretro mame available here except mame2003. : )

@other please don’t talk/ ask about a800 t0 stay in the a5200 topic.

I tried and it’s sort of working…One or 2 games I could play, Others would start and lock up… as I said above.

Does anyone know a good MAME core that works good ?

thanks again for your help ! I didn’t mean to be ungratefull, I just wish I knew how to program, as I would help here.

I think finding a Dev who knows enough about this and who is willing to do it, is a whole different question. Like I said, there isn’t any real love for the 5200 even though it was a great system for it’s day.

The other option is to find a 3rd party emulator and just use that in Emulation Station (as I am using on my front end), I just prefer to keep a smooth interface with LESS programs being installed if possable. There is a lot of 3rd party 5200 emulators out there.

The machine is a dedicated HTPC, so it’s mainly used for TV and Movies with Windows Media Center, so I wanted to add emulation of classic games to it, so I can pick up a 360 controller, click an option, then select a game, then play…

Thanks again !

I got Atari 5200 working on Lakka on a s905 Device, with the amazing core provided by r-type, I did had to compile the core from the repo because the one included in Lakka does not support a5200 keys, and manually configure the core after the first load, but once its all done all of my roms ran fine and I could play Jungle hunt! :smiley:

The part I was missing before was the correct BIOS, once I got that working everything is running smoothly! also, make sure you have “Enable Hotkeys” mapped to something, so that RA and A800 keys (F1, F4, etc) doe not compete with each other.

but I do have a question, I also use ES as my frontend, is there a parameter I could use to force the core to load in a5200 mode? the standalone A800 emulator has this, but not sure if it works with the core ( I have not tried yet)

I hope you have some luck here because it is EXACTLY what I am looking for. Might have to go a 3rd party app if I cant get MAME cores working. Sigh…

Found this one…

It can be scripted so it SHOULD be able to be used with ES… but, I still would prefer not to use a 3rd party app if it could avoid it…

@r-type Is there a way to map “Start Game” to the “Start” button on the gamepad? or is it imposible to do that for some reason?

@DavidinCT this is the option for ES “ -config /path/to/atari5200/atari800.cfg -5200 %ROM%” I haven’t tested it as I am not home, but you might want to try it :slight_smile:

and I am not sure if multiple configs are needed.

1 Like