Can't get some shaders (mdapt) to work

I am trying to use dithering shaders for Mega Drive games. I have tried using mdapt and gdapt and neither seem to show any difference.

I have my driver set to Vulcan, but I’ve also tried to do so with glcore and there is no difference. Any ideas?

Do you have any video filters (that is, the CPU filters you can set up at the very bottom of settings > video) enabled? Those filters include their own scaling that can/will mess with shaders that use pixel pattern algorithms, including mdapt/gdapt.

That worked perfectly, thank you! I had no idea that setting actually did anything.

1 Like