[Download] RetroArch 1.7.7 + other emulators (iOS)

@xdccrlz Ok, can you test this IPA ? http://www.mediafire.com/file/fp2l7p5xkz1qq6b/RetroArchTV_1.7.7.ipa/file

(I think we can delete the back and forth messages to avoid cluttering this topic…) :smile:

The same result: failed to open libretro core(

I think we have situation like mentioned at PPSSPP forum: https://github.com/hrydgard/ppsspp/issues/11905. May be insert string like “syscall(SYS_ptrace, 0 /PTRACE_TRACEME/, 0, 0, 0);” simulated active Xcode debugging help to solve this task? But I don’t no in what part of code I need make this insertion?

@xdccrlz The “problematic” code in PPSSPP is there only to enable the very fast JIT Dynarec, which isn’t officially allowed by Apple, but works fine on a jailbroken device, with proper entitlements added to the app…

I think all 64-bit iOS RetroArch cores already disable any use of JIT Dynarec, and fallback to Interpreter anyway, and the main app doesn’t seem to make use of any JIT Dynarec function neither…

Please try this core compiled specifically for tvOS but added to git by mistake… https://github.com/libretro/RetroArch/blob/45185d682786af37e67c86dd76c7cd1b1c3a4dd1/pkg/apple/Resources/modules/fceumm_libretro_tvos.dylib

If this doesn’t work, I definitely think there is an issue with iOS 13, or maybe only the beta version of iOS 13 (which, from what I heard, doesn’t allow to install some profiles yet, or will not allow them at all…)

Thanks to @xdccrlz’s post, I updated PPSSPP to the latest version on the website and on the repo !

Links updated in the first post…


I am looking for a TVOS13 version for Retroarch on my ATV4k too. Maybe the issue you have is because of the new Apple Development and Apple Distribution certificate types from Xcode 11?

I am no developer, I just want to bring new ideas to help. Please look



The problem discussed is mostly related to tvos 13 than to xcode 11, since retroarch 1.7.7 built in xcode 10.2.1 stopped running cores after switching to tvos 13. Apparently changed the algorithm for checking the signature of the cores in the new system. However, as I reported earlier, Provenance, under the same conditions works fine. Probably because the cores in Provenance is made in the form of frameworks, not a dylib.

If someone on an iOS 13 device could test an .ipa, I would love to hear about RetroArch’s status on iOS 13 as a whole…

On iOS 13 RetroArch 1.7.7 working fine without visible issues.

1 Like

@xdccrlz Great ! That’s good to know it runs on iOS devices with iOS 13 at least…

Just updated the website and the repo with RetroArch’s latest version, the buildbot with the latest cores, PPSSPP to the latest version including WIP external display support, and DOOM’s music for PrBoom with the latest naming convention and added DOOM Sigil’s soundtrack…

Links updated in the first post !

1 Like

@xdccrlz I’m not sure this would work at all, but could you try dropping those two entitlements files in the .app bundle inside the .ipa ?


EDIT : In Target > Build Settings , set the key “Code Signing Entitlements” ( CODE_SIGN_ENTITLEMENTS ) to the file’s path.

Why no one compiled PPSSPP for tvOS. Is this difficult?

@CoderTonyChan As far as I know, no one ported it to tvOS, but it seems you would need to make a new target, hook up the tvOS specific display and controller as new code, as well as network functions and probably some other things…

But as of now, it works great for iOS on an external display thanks to the WIP commit I added earlier, with a cable, and even with AirPlay from an iPhone or iPad to an Apple TV and other supported devices, even supporting wireless controllers such as the mfi-certified ones!


Hi, I’m on iPhone X with iOS 12.1.2 using the chimera jailbreak. I’ve tried downloading RetroArch arch through the repo as well as side loading with Cydia imapctor and I can not get any of the cores to work. No matter which core I try or which rom I attempt to load, I always get the “failed to open libretro core” message. What might I be missing?

@VuduChilde I’m trying it right now…

Edit : Ok, as Chimera bootlooped my test iPhone 6, can you tell me if loading one of the included ROMs with it’s respective core actually works ?

BTW : Use Unc0ver when you can, it’s working way better on anything supported, and never bootlooped my devices… My iPhone X is running great with it, yours should be good too!

Damn, that sucks that it bootlooped your test phone. I’ve tried loading the “content” and allowing the program to choose the “ core itself, and I’ve also tried manually chosen the core to try and manually choose the content to load; both produce the same result.

@VuduChilde Ok, some things to note here… On your screenshot, it shows you actually have a core loaded… Which is different from the one on my buildbot ! (Mine is actually Snes9x 1.60 68bf0fe, BTW…)

  • Is this the Cydia Impactor sideloaded RetroArch ?
  • Is it the iOS 10 version and not the iOS 11+ one ?
  • Is this from the older 1.7.5 post ?
  • Is it loading from the wrong buildbot ? (With “Show Advanced Settings” on in Settings > User Interface, check in Settings > Network > Updater that the buildbot URL is the correct /ios-arm64 one… If not, I may have made a mistake while compiling it…)
  • Did you try the ROMs I included in the package ?

Never mind. Tried to re-download the app from the repo and it sent my phone into a bootloop🥺. RiP jailbreak. Time to hit up Android I guess.

@VuduChilde OMG !!! Did you update Sileo first ? It was updating Sileo on my test phone, then I installed RetroArch, then, bootloop…

I think this whole situation is caused by the latest Sileo update, please don’t install RetroArch on Chimera until we see another Sileo update to fix this issue !!!

Edit : Ok, I filed an issue with Sileo and put a warning on the repo… Please use Unc0ver whenever you can, Chimera IS bad…

@Weedy_Weed_Smoker would you possibly still have access to older builds that you have uploaded throughout this thread? I’ve been enjoying your RetroArch builds since around the time you uploaded the May 26th build and was playing PSX games with the BeetlePSX core without any issues on an iPhone XS Max. Since then, over the past couple builds, I’ve noticed decreased framerates and stuttery gameplay with both PSX cores, as well as the Sega CD cores. The only other build I’ve been able to download, aside from your most recently uploaded RetroArch 1.7.7, is a 1.7.5v3 build, which restores the smooth framerates during PSX games.

Thanks for all your hard work - emulating on the go has been a lot of fun.

@illegalmp3 I think it may be related to me activating the setting “Frame Throttle > Sync to Exact Content Framerate” by default, it unlocks 120 FPS capabilities on supported devices, but I plan to disable it in the next upload, as I think it may be affecting performances…

Please try disabling “Sync to Exact Content Framerate” first and tell me if it was the problem (you can leave Vsync on and Frame Throttle off…)

You were right! I disabled “ Sync to Exact Content Framerate”, enabled V-sync and Hard GPU sync, and the stuttering is gone. Thank you!

1 Like