Free play not working in FBA Alpha

Greetings, I wanted to make the Neo Geo fighting games work in free play, since that in AES mode you get a limited amount of continues and that makes these games brutally hard, but it’s not working. What could be the reason?

bios related? Try universe bios

I tried and it didn’t work.

Have you heard of Final Burn Neo? Is the new and improved continuation of the now dead FBA.


I cant get neogeo games to boot at all with an AES bios in FBNeo (black screen no audio) but just stick it in MVS mode. The games are identical and you can either use as many credits as you want or set free play in the dip switch settings.

Assuming you followed documentation ( and are using the right romsets, AES in FBNeo works perfectly. Careful though : the “CPU Clock” and “Enable Cyclone” core options are known for breaking a few games, stick with “CPU Clock” at 100% and “Enable Cyclone” disabled if you don’t want issues.

1 Like

Yeah my roms are fine, they’re from the latest MAME set and I don’t have any of those other options enabled. They work perfectly in default MVS mode, but when i switch to AES mode in the core options they don’t even boot, i just get a blank screen.

That’s weird, i can’t reproduce on my computer.

  • What’s your platform ?
  • Is it happening with specific games ? I know there are some games not compatible with AES, but the core should automaticaly force MVS in the first place for them.
  • Is it also happening when you set Neo-Geo mode to unibios or dipswitches (+ the BIOS core option below) ?
  • Please provide logs.

I tried Final Burn Neo and free play works with this one, but I just learned that you can continue your game in AES mode if you used a memory card and this would be preferable for me since AES has more options available, but it’s not working. I have memory card set as “Writable” and new card type as “1 Megabit”. Is this correct?