Hotkey issues


#1

Hi,

Iam having a strange problem ,

iam using a retrolink USB controller in conjunction with the Nestopia core to play my NES games. My problem is that the select button ( button 8 in RA ) does nothing in game when also used as the hotkey button. In other words, the select button triggers the hot key functions fine but the in game select function does not work.The weird thing is that the problem only occurs in some games like Startropics where you need the Select button to browse trough the main menu ( legend of zelda uses the same menu sys and it works fine here ). Unfortunately the retro link nes controller does not have a extra button where i could map the hotkey function to, and i dont relay want to use the 360 controller cause i spent a lot of money on retro controllers for my emu’s.

Does anybody know a solution or a workaround for that problem ?

thank you in advance :slight_smile:


#2

Hotkey toggle blocks core inputs by design.


#3

Thx, for the answer

i guess iam shit out of luck then, and i have to play the games without hotkeys on the controller. But when the hotkey button is coded like that by design, why is it working in most of the games and is some it does not ? Like i was saying, in legend of zelda which also uses the select button (witch is also my hotkey trigger ) to move the index up and down in the file select screen, it works fine. So it does its job as the game select button and also hotkey trigger. In some games the mapped hotkey button does not execute its main function and only works to trigger the hotkey functions. That puzzles me. Iam missing something here or maybe im just stupid ?


#4

There’s a hacky workaround for this in retropie that never got merged into mainline RA that sets up a timer such that it does the normal function until the timer hits, and then it starts blocking everything.


#5

[QUOTE=smackm;41478]Thx, for the answer

i guess iam shit out of luck then, and i have to play the games without hotkeys on the controller. But when the hotkey button is coded like that by design, why is it working in most of the games and is some it does not ? Like i was saying, in legend of zelda which also uses the select button (witch is also my hotkey trigger ) to move the index up and down in the file select screen, it works fine. So it does its job as the game select button and also hotkey trigger. In some games the mapped hotkey button does not execute its main function and only works to trigger the hotkey functions. That puzzles me. Iam missing something here or maybe im just stupid ?[/QUOTE]

That doesn’t sound like you’re missing something. That sounds like a (beneficial) bug.


#6

[QUOTE=smackm;41478]Thx, for the answer

i guess iam shit out of luck then, and i have to play the games without hotkeys on the controller. But when the hotkey button is coded like that by design, why is it working in most of the games and is some it does not ? Like i was saying, in legend of zelda which also uses the select button (witch is also my hotkey trigger ) to move the index up and down in the file select screen, it works fine. So it does its job as the game select button and also hotkey trigger. In some games the mapped hotkey button does not execute its main function and only works to trigger the hotkey functions. That puzzles me. Iam missing something here or maybe im just stupid ?[/QUOTE]

It works on some games because those games react to input in the same frame. Some other games may react later, or only when the button is held for a while.


#7

First of all, thank you for the help

so now i understand, if the game reacts to the button press with a slight delay it will not work. A work around would be to trigger the hotkey function a couple of frames in i assume. Maybe if iam lucky, something like that will be implemented in an update.


#8

Well that completely explains why I’m having issues with it on my PC build as it works perfectly on my retropie and all I tried to do is duplicate it to the RA version on my android and PC… what would I search to find the workaround? I’m searching through the retroarch.cfg file but cannot find where to add it


#9

it has to be compiled in. It’s not a config thing.


#10

Gotcha, first off thanks for replying to a 2+ year old thread, secondly any recommendations for setting up an N64 controller hotkey in RA as most controllers use all the buttons and there is no select button?

Thanks


#11

I would probably use the N64’s L button, as very few games use/require it.