How to configure mouse as light gun? And light gun as mouse?


#80

Update i had a rouge game opt file overriding mouse to pointer. Lol

All working on my laptop.


#81

Nice! I hope more and more people start to take advantage of this feature


#82

Its really cool. I dont think theres anything more fun than 5mins of dual lightguns with a mate.

I really hope the feature gets polished off over time. If only it makes it into current mame core


#83

i managed to get fceumm to support dual-mouse inputs as seen in pic with player1/player 2 scoring:

:

but i dont understand how both players can play at the same time since mouse moves the same cursor and the core only has one crosshair.


#84

With my testing at 1st both mouse controlled one crosshair. Maybe its not actually registing 2 mouse devices. But the fact it has both players scores is odd.

Have you found a video of the original game to compare gameplay to?


#85

which core are you testing?


#86

Sorry just the mame2003 core


#87

i am only able to move one crosshain in area51, maybe this multimouse thing does not work well with udev

Update: Ok im using Windows now and area 51 still does not respond to 2nd mouse. i use fceumm to confirm that both mouse have its own port(normal nes uses main mouse-which zapper is connected to player2, VSuni roms using 2nd mouse, which is connected to player 1) But area 51, only the 2nd pointer moves.

[INFO] [WINRAW]: Mouse #0 \\?\HID#VID_24AE&PID_2001&MI_01&Col01#8&3e391eb&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}.
[INFO] [WINRAW]: Mouse #1 \\?\HID#VID_09DA&PID_90A0&MI_01#8&6a2bfd7&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}.

Update: controls are wrong here. its moving the other crosshair while its shooting on the crosshair that is not moving.


#88

Mouse buttons may be swapped in Area 51 settings (‘P1 button 1’ and ‘P2 button 1’).


#89

With 88 posts in this thread, I think it would be good to have a separate thread as a guide for configuring multi-mouse, separate from the ongoing development/testing conversation.

I’m hoping that more people will begin using this feature soon, and that it will be useful to have some standard instructions available for reference: Configuring RA for multi-mouse (spinners, lightguns, tackballs)


#90

To whom it may concern: casdevel completed an overhaul of the udev input driver including support for absolute mouse devices like the Dolphinbar/Wiimote. Grab the latest version from git or the buildbot to give it a try.

This means that Linux users, as well as (some?) Android users and OS X users should be able to use lightguns including multiple simultaneous lightguns.


#91

Just a quick test update. Tested using a Wiimote+DolphinBar again on various NES and SNES cores in WIndows 10. Cursor sensitivity is still much too high to be playable on every core I tested except FCEumm, which works well if Zapper Mode is set to pointer.


#92

How far are you from the Dolphinbar when testing?


#93

About 6-7 feet, I think it only got wacky when you were really close, at least on the actual Wii.


#94

I have the same setup (Wiimote + Dolphinbar) for my Raspberry Pi 2B with the latest version of Retropie (4.4) which came out in April. I’ve been “away” from all of this for quite awhile but I am starting to play around with it more and before my hiatus of sorts, there was no support for any consoles, so I was thrilled to see that NES (lr-fceumm) light gun games work great with no calibration, but i didn’t have any issues with sensitivity (got to level 10 on Duck Hunt). Were you testing yours on a Windows system? And out of curiosity, have you tested any Sega Master System games, because those are the ones I’ve really been waiting for since it was my first system and those games aren’t really available on other platforms.


#95

Hi guys, could someone give me a hint,what am I doing wrong, please? I have latest retroarch running on laptop with win 10 (Both 64-bit). I am trying to get it worked on Nestopia core. I have file NstDatabase.xml in System folder of retroarch. When I run game(duck hunt,wild gunner,chiller), I can move crosshair,but I cannot shoot. Mouse/touchpad buttons just do not work. What am I missing? I tried to change Mouse index couple times and I also bind mouse buttons to default keyboard buttons (a,z,x). Also tried every combination of input and joypad drivers. Nothing worked. I read many discussions,but people could usually shoot,but not aim. I have exactly opposite problem. Thanks in advance got any help.


#96

Have you tried changing your driver from xinput2 to raw in settings > driver?


#97

Yes,I tried every driver and also every joypad driver.I did not know,if this could help or not. Is mouse with buttons supposed to work right away or do I have to bind keys somewhere? Mouse buttons work correctly in retroarch menu,but not in Nestopia games.


#98

I got it working on FCEUmm,but not on Nestopia on win10. On Android Tv works air mouse just fine with Nestopia.Weird,but at least it’s working. :slight_smile:


#99

Hi everyone, I’ve installed an Ubuntu 16.04 system with emulationstation. I’ve tryed to configure my mouse to use it in shooting game but with some problem. I can use the mouse button as game button, but I can’t move the cursor (and I can’t see a cursor).

Can you help me with the correct configuration?

Best regards