[iOS/tvOS] — RetroArch 1.9.0 and other emulators (Download/Cydia repo)

Can anyone get this working? Crashes every time on tvos when entering pipe. So i tried it on ios and was working at first but now the same thing happens. https://youtu.be/nKeoVO5jNxE Patch in description

@Trebrick You must go to the front of the castle and launch the Lakitu cameraman “cutscene” first, then enter the pipe… If the cutscene didn’t play yet, it will crash!

@Weedy_Weed_Smoker just tried again seems it crashes every time after the first (if the game doesnt save progress). If progress is saved there is no crash but there are graphic glitches in yoshi garden. Only thing that works for me is to do a save state inside yoshi garden on the first time playing the rom. Then load state and save progress and it seems to work fine after that.`

@Weedy_Weed_Smoker should the fixes for the official build be live? @chibk27 is saying cheats are not working for him. I pointed him to your build.

@Trebrick Yes, cheats work fine with my version!

They are just not yet included in YoshiSuga’s version on retroarch.com

@Weedy_Weed_Smoker hey, ever get around to trying that chd argument? Not work?

@Trebrick Oh yeah, not yet… I’ll hopefully get around to try it before 1.9.1 gets out!

@Weedy_Weed_Smoker Ah no rush just hoping its the solution

@Weedy_Weed_Smoker Ah looks like I get the logo hanging problem again on my iPhone :frowning:

Is it working on iOS 14.1? It crashes whenever I open it, it is a fresh install so I don’t know what could be the problem.

I have a crash log here, just in case it’s of any help https://pastebin.com/XtBu8bNb

Hi guys, how did you make RA 1.9.0 work on iOS? I downloaded the newest .ipa, but it crashes on my new iPad immediately after loading a core. no matter if content is loaded or not.

@Weedy_Weed_Smoker hey hope all is well, been awhile. Just thought id post something. With the news of JIT support in ios 14.2 cant wait till an updated dolphin core is built! Also super stoked for the pcsx2 core… though seems like no mac support.

1 Like

Hi @Trebrick!

Hope all is well for you too! With RetroArch crashing on iOS 14, I definitely will try to update it now… PPSSPP is crashing too, but that may be fixable by disabling JIT, which is kinda sad but I’ll try to update that too, and hope for the best…

Unfortunately, my tvOS certificate expired, so I’ll be able to compile iOS versions only…

@Weedy_Weed_Smoker Oh im still on 13 i didnt even know about the crashes, dang. Well hopefully some things can get ironed out for 14 eventually. And hopefully a certificate shows up outta thin air for ya haha. But hey ios is better than nothing.

1 Like

Ok, I tested some more and it’s only crashing when escaping the sandbox (which is very annoying as this is pretty useful, I’ll test some more…), but other emus escape it with no problems!


EDIT: I will have to make a sandboxed version only for iOS 14, for now… Coming soon!

Managed to get it working on iOS 14, with the sandbox escape, no need for a separate version!

The downside is that it may very well break on Chimera (or maybe other jailbreaks), please report any issues you might encounter with it!


I lost my tvOS certificate so only iOS versions are updated…


@Trebrick Just looking at the previous posts, I completely forgot to test the -DHAVE_CHD argument… :cold_sweat:

@Weedy_Weed_Smoker haha no worries. Hopefully if and when u get around to testing, its the solution! Also, dang nice work finding a sandbox solution without having to make a new version. Think ima switch to 14 on ios soon so ill give your new fix a try when i do. Last thing, u tried the new dolphin ios yet? Any plans of updating your version?

@Trebrick I will try to update my Dolphin version, but mine merged the supporting library “csdbg” from OatmealDome’s repo directly inside Dolphin, and I think that might be causing issues…

I may have to add it separately again, for now I think people will just see the update notification from inside the app and update directly from OatmealDome’s repo, it was mainly so people are aware Dolphin exists on iOS but, hey! I might just do that…

1 Like

@Weedy_Weed_Smoker Ah i see, And yah im sure itll still raise awareness… also its nice to have your repo as the one stop shop haha. Either way thanks again for the hard work as always.

1 Like