Lakka Nightly binary config.txt on pi4


I tried the last two Lakka nightlies. The problem is that when I dd the img file to the microSD, and try to edit config.txt that the file is binary instead of ASCII. This was not the case with older nightlies.

$ file *.txt
cmdline.txt: ASCII text
config.txt: data
distroconfig.txt: data

I need to edit config.txt as my display will not work with the default HDMI power level of the Pi (I need at least config_hdmi_boost=4). Otherwise the display will simply claim there is nothing detected and switch itself off.


That looks like a corrupted file to me, are you sure you’re doing it correctly?

Well, the files came out of the img.gz file like that. I unpacked it more then once and the cmdline.txt is a regular ASCII file like it should be, so it is not like everything is binary. In addition, it worked fine with older nightlies.

steps taken: gunzip .img.gz sudo dd if=.img of=/dev/sdb

edited to format steps

I just downloaded and unpacked the latest nightly (2019-09-14) onto a microSD and config.txt is once again in ASCII format. So whatever caused the problem has been fixed.