MAME games Android problem

I made two short videos for you to see what exactly happens

BIOS boot only here

Start .cmd game file here

I will try to create a .log file thank you for your help :slight_smile:

@Duimon I managed to create a .log file here is its content here

parse path failed! path=-ui_active.

-ui_active is also a standalone MAME switch, is not needed, and is last so interpreted as the path.

Just remove it from the command line.

To be clear… your command line looks correct in your log except for the last bit.

Change

fmtmarty -cdrom "/storage/emulated/0/ROMS/Marty/Flashback.cue" -rompath "/storage/emulated/0/RetroArh/system/mame/roms" -ui_active

To

fmtmarty -cdrom "/storage/emulated/0/ROMS/Marty/Flashback.cue" -rompath "/storage/emulated/0/RetroArh/system/mame/roms"

and you should be good to go… as long as your config/MAME/fmtmarty.opt has the mame_softlists_enable = "disabled" in it.


Edit. To actually get this to work I had to switch the order of the -rompath and the -cdrom targets. I also had to encapsulate the entire MAME command by adding an extra " at the end. (The beginning would also work.)

My command is…

“E:/RetroArch/retroarch.exe" -L “E:/RetroArch/cores/mame_libretro.dll” "fmtmarty -rompath “E:/Temp/fmtmarty” -cdrom “E:/Temp/fmtmarty/4d.chd”"

Here is a shot of it running in the Mega Bezel with my FM-Towns-[STD]-[Guest]-[Monitor] preset.

@Duimon thank you for your help here is the content of my .cmd file:

fmtmarty -rompath "/storage/emulated/0/RetroArh/system/mame/roms" -cdrom "/storage/emulated/0/ROMS/Marty/Flashback.cue"

As you can see I changed the order of the commands the BIOS statement is first I removed the -ui_active command & the slashes are the right way round (/) :slight_smile:

I also disabled this option: mame_softlists_enable = "disabled"

Despite all these changes I still have a black screen… I do not know what to do ??? I would like to know why you show me the example with the Windows version of MAME libretro & not that of Android ?!

Can you do the test on your phone ? Thanks

[EDIT] the bezel is beautiful :heart_eyes:

Because I do not have an android phone. I do have an android device in the closet I may break out. I have some concerns. Mostly that @sanchezmike01 is using the “-ui_active” switch, which shouldn’t work.

And I just wanted to show off. :grin:


Try this. Create an fmtmarty.ini in your “Retroarch/system/mame/ini” folder.

Inside have the lines…

rompath                   /storage/emulated/0/RetroArh/system/mame/roms
inipath                   /storage/emulated/0/RetroArh/mame\ini

Then add the line…

mame_read_config = "enabled"

to your fmtmarty.opt file. If it’s still a rompath issue this should solve it. You should also be able to remove the rompath line from your command.

Please post another log with your results.

@Duimon Here are the changes I made:

  1. I unpacked the fmtmarty BIOS into a folder:

-rp /storage/emulated/0/RetroArch/system/mame/roms/fmtmarty/

  1. I converted my Flashback game from .bin / .cue to .chd & changed the argument like this:

-cdrom /storage/emulated/0/ROMS/Marty/Flashback.chd

  1. I created an fmtmarty.opt file which I copied into /storage/emulated/0/RetroArch/config/MAME/ here is its contents:

         mame_alternate_renderer = "enabled"
         mame_altres = "640x480"
         mame_auto_save = "disabled"
         mame_boot_from_cli = "disabled"
         mame_boot_to_bios = "disabled"
         mame_boot_to_osd = "disabled"
         mame_buttons_profiles = "enabled"
         mame_cheats_enable = "disabled"
         mame_cpu_overclock = "default"
         mame_lightgun_mode = "none"
         mame_mame_4way_enable = "disabled"
         mame_mame_paths_enable = "disabled"
         mame_media_type = "cdrom"
         mame_mouse_enable = "disabled"
         mame_read_config = "disabled"
         mame_saves = "game"
         mame_softlists_auto_media = "disabled"
         mame_softlists_enable = "disabled"
         mame_throttle = "disabled"
         mame_write_config = "disabled"
    

But despite all this nothing works I still have a black screen I’m going crazy !!! Why is nothing working ???

Here is the latest .log file here

[EDIT] in the fmtmarty.opt file I changed the line mame_media_type = "rom" in mame_media_type = "cdrom" I don’t know if this is a good idea ?!

@haojiezhu why did you delete your posts ??? I would like to try your method thank you !

You need mame_boot_from_cli = "enabled"

Ui_active may not be necessary for this system, but on Android it does work on the ini file or cmd file…I do it via batch file so I keep it always in there just in case…sord M5 is such a system that if u don’t have it there, u will need to press scroll lock on the keyboard beucase the tab button won’t work…also not all android keyboards have the scroll lock button…

Makes sense since there is no keyboard.

Interesting then that the first log showed an error related to it. I’m starting to wonder if something else is causing an issue, this really shouldn’t be this hard.

I just unpacked my shield (recently moved)…I have that and a ton of non arcade games working on mame for RetroArch android including systems with no xml…thats another thing…someone said to him to make sure u have an xml…no need for that with cmd files…I rename all my roms to insure a pacman from a computer system won’t load with a bezel from the arcsde rom because they have the same identical rom name…between that and ppl stealing ur work and selling it, then saying they were the master mind of it…lmao…the only roms I don’t rename are mame arcade roms…literally everything else is renamed …u may think it’s too much work but it’s done in seconds with apps and batch scripts

All that sounds very impressive. Do you know the command to boot from a floppy and then run a CD?

One thing the hash XML does is automatically take care of that sort of thing. While the command line can greatly increase the playable rom count, it can also be limiting.


That being said… I have no idea why the OP is having such a hard time getting this to run.

With enough patience I have never failed to get a non-arcade system up and running… if it will run at all.


Not at all. I have hundreds of hours into my HTPC. It only needs to be done once and you may as well do it right.


I would really appreciate your insight to the bootable floppy >>> cdrom floppy thing.

Why don’t you give an example of the contents of your .cmd files ? No one replied to my last message ? I posted the .log & showed the latest changes I made but no one responded ? What must I do now ?

I replied. :innocent:

I think you have this disabled in your opt file. You need it enabled to use the command line.

(cli = command line)

@Duimon I just tried I activated the option in my two .opt files it doesn’t change anything I always have a black screen… it’s hopeless !

1 Like

I know it seems that way, but if someone else has it working then there is always hope. Can we see the latest log?

@sanchezmike01 Can I see a log of a successful launch so we can compare them. I’m sure it has something to do with command line syntax. Question… are you also launching a *.cmd as content?

U have to understand, I don’t mind helping out…but I have a wife and 2 small girls and I work from 6am till 9pm 6 days a week…so if I didn’t post up , it’s most likely because I been out at work all day and when I unpacked my nvidia shield, my wife called me to spend time with me…I don’t have the luxury of having tons of free personal time…I wake up at 430 everyday and try to be in bed early to do it all over again the next day…I just can’t load things up and then record and post it on here…sounds easy but when your family hasn’t seen u all day and want to spend time u have to make that executive decision to put the electronics down and be a husband and a father

As far as cmd files, all my mame systems including arcade games are launched via cmd files…even my chds are launched via cmd directly…meaning no zips files or subfolders…all my chds are loose in 1 folder with the cmd files in that same 1 folder…as far as chds and disks, I wrote it all on the cmd file…so it will be something like -flop game name then the location and in the same file -cdrom game name and location…and it loads fine…everything I write on the cmd…like acorn archimedes…it must have a specific bios written down to properly load…I also write diwn any auto boot commands so it can load directly instead of me having to do extra work to get it to load…the only physical part I have to do is press F2 for tape play

1 Like

Cool. When you have time I’d like to see a log of a CHD successfully running so I can get a look at how the log shows the command line.

Please, take your time… no one has a deadline here. :grin:

1 Like

Good evening friends ! I have very good news :slight_smile:

I started from scratch on my girlfriend’s phone & I did a lot of tests to understand better… here is the summary of these tests :slight_smile:

I finally managed to launch the FM Town Marty console with my Flashback game !!! I will detail the procedure so that it can also be useful to other people.

Here is the content of my Flashback.cmd file which allows the launch of the game:

fmtmarty -rp "/storage/emulated/0/RetroArch/system/mame/roms/" -cdrom "/storage/emulated/0/ROMS/Marty/Flashback.chd"

  1. It is very important to declare the BIOS first on the command line. I tried to declare it in second position it does not work !

  2. It is very important to respect the case -> example: /RetroArch/ & not /Retroarch/

  3. It is necessary to declare the paths in quotes (" ") otherwise it will not work.

  4. The .cfg .opt .xml files are not necessary I deleted them voluntarily to test it works all the same.

  5. There is no need to unzip the BIOS just declare the correct path to .zip file

  6. For Marty console Flashback game in .cue / bin format works as well as .chd format

  7. It is not necessary to activate the CLI (command line) in the MAME.cfg file it works without.

I also tried another machine that I really like: the TRS-80 Color Computer. Here is the content of the .cmd file that allows the launch of the Donkey King game:

cocoe -rp "/storage/emulated/0/RetroArch/system/mame/roms/" -flop1 "/storage/emulated/0/ROMS/Color Computer/Donkey King.dsk" -autoboot_delay 2 -autoboot_command loadm\"donkey\":exec\n

Now I have a question because the game launches correctly but I remain stuck at a specific place… indeed at this place it is necessary to press the space key on the Color Computer keyboard & on MAME libretro it does not there is no virtual keyboard… how to proceed ?!

Is there a way to have a virtual keyboard on RetroArch ?!

Greetings :slight_smile:

1 Like