I started this project in Linux and had issues running games. After looking in to this further, I’ve decided I want to run LaunchBox as this PC will go in to my custom build arcade cabinet.

I think I understand most of my problem is lack of video card. I only have the internal card. I do have Windows 10 fully updated and I do have directX installed.

Some PC specs: Board - ASUS P5G41-M LX2/GB Processor - Intel Celeron E3400 2.60GHz Dual Core Ram - 4GB

My main issue is I cannot run games. I have all cores updated. These are no-into ROMS that should work. But RetroArch will tell me “failed to load content”. This was also happening when I attempted this on the Linux side. It was a little better though. As of now I have a couple new symptoms. Now, my RetroArch UI no longer shows the PS background, the waving animation. I also cannot see notifications from the UI. They look like blocks. Maybe I’m missing a font.

I do plan on getting a video card for this machine before I put it in an arcade cabinet. If anyone could point me in the right direction on getting this to run some games. I’m currently trying to load Nintendo - Family Computer Disk System. I’ve tried all 3 Famicon cores it allows me to try.

We would need a log to know why things aren’t loading. https://www.youtube.com/watch?v=oz9QNBtYrr8

Here is my launch log. It appears there might be some font issue that would explain why I cannot see notifications at the bottom of the RetroArch UI.


This is a log of the game failing.


I also find it weird am on a 64 bit machine and see this line.

[INFO] [Video]: Found display server: win32

Screen shot of the font problem.

It appears those games needed bios added. So I did get good Nintendo game running. But it was painfully slow. I have MAME installed and had it running a much richer game than the Nintendo game and it was running fine. I still cannot read the notifications from the RetroArch UI. maybe there’s some optimizations I need to setup?

[INFO] [GL1]: Vendor: Microsoft Corporation, Renderer: GDI Generic.

Here’s at least some of your issue. Since it’s old and running Windows, I would suggest trying to switch to the d3d10, d3d11 or d3d12 driver. If none of those work, try d3d9.

1 Like

I was thinking same thing.

I have a Laptop that does not work with Open GL but the Direct Video Codecs worked fine especially number 10

With your guys experience, will it get better if I put a video card in this PC? I still have to look up what video card options I have with this board. Thanks guys, I will give this a shot tonight.

Yeah, a modern video card (doesn’t have to be powerful, just able to use up-to-date drivers) would indeed help, but try the d3d drivers first. You won’t be able to play GL cores, like mupen64plus-next, but all software-rendered cores should work fine.

1 Like

d3d10 has it working much better. I can read the notifications, see the background animation, and the game ran much smoother.

You guys have any recommendations on understanding what you need to run a ROM? My understanding is older systems usually need one file as MAME and some other systems need BIOS or more than one file. I found a couple Sega games. They were .sms and .smd files. Neither are recognized by RetroArch. Are there supporting files for a console like Sega? Trying to learn as much as I can. But I seem to miss a lot of fundamentals or just bad information.

1 Like

docs.libretro.com has most/all of the information you need. It will tell you which cores need which BIOSes, etc.

1 Like