PS1 ROM Crashes App

Hi Everyone,

New here, so apologies if I’ve missed something…

I’m trying to get Retroarch to run a couple of PS1 ROMS using reARMed or Beetle, and it’s constantly crashing.

Phone is Samsung GS20+ with he exynos chip (not Qualcomm).

Log is as follows -

Updating firmware status for: /data/user/0/com.retroarch.aarch64/cores/ on /storage/emulated/0/RetroArch/system Using content: /storage/emulated/0/RetroArch/downloads/240pTestSuitePS1.cue. arg #0: retroarch arg #1: /storage/emulated/0/RetroArch/downloads/240pTestSuitePS1.cue arg #2: -s arg #3: /storage/emulated/0/RetroArch/saves arg #4: -S arg #5: /storage/emulated/0/RetroArch/states arg #6: -c arg #7: /storage/emulated/0/Android/data/com.retroarch.aarch64/files/retroarch.cfg arg #8: -v Content ran for a total of: 00 hours, 00 minutes, 00 seconds. Unloading game… Unloading core… Unloading core symbols… Threaded video stats: Frames pushed: 11839, Frames dropped: 0. RetroArch 1.8.7 (Git 12af4ed) Redirecting save file to “/storage/emulated/0/RetroArch/saves/240pTestSuitePS1.srm”. Redirecting save state to “/storage/emulated/0/RetroArch/states/240pTestSuitePS1.state”. === Build ======================================= Capabilities: ASIMD [INFO] Built: May 18 2020 [INFO] Version: 1.8.7 [INFO] Git: 12af4ed [INFO] ================================================= jni_thread_destruct() Loading dynamic libretro core from: “/data/user/0/com.retroarch.aarch64/cores/” [Overrides] no core-specific overrides found at /storage/emulated/0/RetroArch/config/PCSX-ReARMed/PCSX-ReARMed.cfg. [Overrides] no content-dir-specific overrides found at /storage/emulated/0/RetroArch/config/PCSX-ReARMed/downloads.cfg. [Overrides] no game-specific overrides found at /storage/emulated/0/RetroArch/config/PCSX-ReARMed/240pTestSuitePS1.cfg. [Environ]: GET_LOG_INTERFACE. [Environ]: GET_LANGUAGE: “0”. [Environ]: RETRO_ENVIRONMENT_SET_CORE_OPTIONS_INTL. [Remaps]: remap directory: /storage/emulated/0/RetroArch/config/remaps Redirecting save file to “/storage/emulated/0/RetroArch/saves/240pTestSuitePS1.srm”. Redirecting save state to “/storage/emulated/0/RetroArch/states/240pTestSuitePS1.state”. [Environ]: GET_VARIABLE pcsx_rearmed_memcard2: disabled Memcard 2: disabled Starting PCSX-ReARMed Running PCSX Version 1.9 (May 22 2020). mapping main RAM failed PSX emulator couldn’t be initialized. PCSX init failed.

Any ideas what is happening?



1 Like

240p test suite doesn’t run on either core currently. Have you tried any other games?

Yep. Have tried Jet Moto and F12007, both of which give the same failure.

Strangely (or not?) both work on GS9.

1 Like