RetroArch 1.7.8 For Linux - Problems with Manual Compilation

Hi there, i decide to upgrade my Retroarch 1.7.6 to Retroarch 1.7.8 but in the first try i use the follow commands :

On Devuan ASCII (64 Bits)

./configure \
--disable-systemd \
--enable-ffmpeg \
--enable-caca \
--enable-debug \
--enable-rgui \
--enable-materialui \
--enable-xmb \
--enable-ozone \
--enable-ssl \
--enable-builtinmbedtls \
--enable-video_layout \
--enable-sdl \
--enable-sdl2 \
--enable-libusb \
--enable-dbus \
--enable-udev \
--enable-thread_storage \
--enable-ssa \
--enable-dylib \
--enable-networking \
--enable-networkgamepad \
--enable-miniupnpc \
--enable-builtinminiupnpc \
--enable-opengl \
--enable-xrandr \
--enable-xinerama \
--enable-kms \
--enable-wayland \
--enable-egl \
--enable-vg \
--enable-cg \
--enable-builtinzlib \
--enable-zlib \
--enable-alsa \
--enable-rpiled \
--enable-tinyalsa \
--enable-oss \
--enable-al \
--enable-jack \
--enable-pulse \
--enable-freetype \
--enable-xvideo \
--enable-v4l2 \
--enable-sse \
--enable-flac \
--enable-builtinflac \
--enable-preserve_dylib \
--enable-parport \
--enable-mmap \
--disable-qt \
--enable-xshm \
--enable-lua \
--enable-vulkan \
--enable-osmesa \
--enable-videoprocessor \
--enable-cdrom \
--enable-slang \
--enable-glslang \
--enable-spirv_cross \
--disable-wayland \
--prefix=/usr ; \
export {C,CXX}FLAGS='-O2 -fPIC -march=native -mtune=native -pipe' ; \
export OPTFLAGS='-O2 -fPIC -march=native -mtune=native -pipe' ; \
make ; \
su -c "make install ; ldconfig" root

On Slackware64 14.2 :

./configure \
--disable-systemd \
--enable-ffmpeg \
--enable-caca \
--enable-debug \
--enable-rgui \
--enable-materialui \
--enable-xmb \
--enable-ozone \
--enable-ssl \
--enable-builtinmbedtls \
--enable-video_layout \
--enable-sdl \
--enable-sdl2 \
--enable-libusb \
--enable-dbus \
--enable-udev \
--enable-thread_storage \
--enable-ssa \
--enable-dylib \
--enable-networking \
--enable-networkgamepad \
--enable-miniupnpc \
--enable-builtinminiupnpc \
--enable-opengl \
--enable-xrandr \
--enable-xinerama \
--enable-kms \
--enable-egl \
--enable-cg \
--enable-builtinzlib \
--enable-zlib \
--enable-alsa \
--enable-rpiled \
--enable-tinyalsa \
--enable-oss \
--enable-al \
--enable-jack \
--enable-pulse \
--enable-freetype \
--enable-xvideo \
--enable-v4l2 \
--enable-sse \
--enable-flac \
--enable-builtinflac \
--enable-preserve_dylib \
--enable-parport \
--enable-mmap \
--disable-qt \
--enable-xshm \
--enable-lua \
--enable-vulkan \
--enable-osmesa \
--enable-videoprocessor \
--enable-cdrom \
--enable-slang \
--enable-glslang \
--enable-spirv_cross \
--prefix=/usr ; \
export {C,CXX}FLAGS='-O2 -fPIC -march=native -mtune=native -pipe' ; \
export OPTFLAGS='-O2 -fPIC -march=native -mtune=native -pipe' ; \
make ; \
su -c "make install ; ldconfig" root

And well in too distros i got the same result after i compile RetroArch 1.7.8 “Segmetation Fault”

After i decide simplify the options i put and just leave the follow :

./configure \
--disable-systemd \
--enable-ffmpeg \
--enable-debug \
--prefix=/usr ; \
make ; \
su -c "make install ; ldconfig" root

Well the thing is i enter on “Online Updater” but i don’t see the option “Core Updater”

Dunnos

  1. Was an option disable the Core Updater?

  2. I need compile manually any core i want to try?

  3. Online don’t exist core available for this version of retroarch?

  4. I use the “Content Downloader” and i get “Wolfenstein 3D” but i don’t had idea why don’t appear in any part of RetroArch.

Thanks for any useful answer you can give me.

There is an option to show/hide the core downloader in settings > user interface > views, but some distros patch it out altogether. Are you getting your source from the distro or from github?

1 Like

I had download with command :

git clone https://github.com/libretro/RetroArch.git

Ok, it should be intact, then. Probably just hidden.

1 Like

Yes, thank you, but in this version is Hide by default?

Because when i compile 1.7.6 that option was show by default, and that its quite strange for me because its are the same distros.

No, definitely not default. Try moving your ~/.config/retroarch/retroarch.cfg file somewhere else temporarily and see if it shows up.

1 Like

Yes, i move and the options appears fine, and take the system language :smiley: i enter on the Core Uploader Section

i notice now says “core_type_libretro.so.zip” like “bsnes_accuracy_libretro.so.zip” instead “SuperNintendo (Bsnes Accuracy)”

That means your core info files are not in the right place, either. You can refetch them from the online updater.

1 Like

Solved Thanks for the help