Retroarch on CRT, certain cores not outputting signal

Where did you see those options suggested? I ask because I think the custom viewport settings are forcing one resolution and then switchres is trying to do another, and that could be the source of your out-of-sync signals.

I’m also not sure whether it works with d3d11 vs gl video driver or if it matters. and

are the latest ones i remember seeing…but seen those setting more than just those 2 times

I kinda made some progress. I noticed in the log file it was setting fullscreen to 640x480 @ 60Hz. The crt can only handle 480i so figured that may be a problem and in RA went to video>output> and set it to 640x480 @30 . After that everything started working when launched from retroarch. And everything appears to be running in 240p with nice scanlines.

So then I head to launchbox/bigbox and try it out… still a scrambled screen :frowning:

Hmm, well, good to know that d3d11 works. (the CDCRUZE tutorial has nice web design)

Glad you got it working launching from RetroArch, at least. I’m not sure what would be going wrong from Launchbox.

Ive tested more cores from RA directly and everything is working good, but from bigbox its still out of sync or unsupported signal or whatever is causing the scrambled image. Ive been at it for days and cant figure it out. Still open to ideas if anyone has any thanks

Is there any chance launchbox is using a different config file? You can specify a path to a config in your launch line with -c C:\path\to\config.cfg

That is what I was going to look into next… but if im running bigbox do I need to even worry about launchbox? It seems they behave independently from one another. Launchbox still opens where it wants and bigbox opens to whatever screen I have it set to but cant find this option with launchbox. What i mean to say … do they have different config files and where are they located? And if running bigbox does it just run bigbox config or does it rely on launchboxes as well?

Do you have the crt as the primary monitor and are you launching LaunchBox and BigBox from the crt as the primary monitor? Even if you are launching retroarch to a 2nd monitor within BigBox it will not work correctly with crt emudriver if the crt is not the primary monitor. Also if you have your emulators set up correctly in LaunchBox there is no separate settings for the emulators in BigBox.

1 Like

I have display #1 set to motherboards integrated video out so that my system doesnt load a harmful out of range signal to the crt during boot, display#2 is my ultrawide and display #3 is the crt set as primary. Ive tried it almost every way possible but yes currently the crt is primary, ive ran bigbox from the crt and the ultrawide same issues either way.

Im in retroarch again and cant get anything to run right once again like its putting out the wrong signal. Ive spent days trying everything I can think of in settings. I had it working that one time by setting video output to 640x480 at 30hz. I did this because in verbose log file it shows ra starting at 640x480 at 60hz which this crt cant handle, before switching to a super resolution. Somehow last time it made it work, this time i just have an out of sync menu. I dont think setting video output to 640 x480 30 should of worked when it did because it should of been left on auto to use the 240x2560 super res, or set to 240x2560 but ive tried that too and same squished horizontal image of my desktop every time i try to load a rom

Ok, playing around with setting in RA for several days has gave me a hunch of whats going on and im able to replicate it but dont know how to resolve the issue.

In retroarch when I open it directly the menu is clear like its in progressive mode and no rom from any core will launch right, ill get sound but still just see a darkened squished horizontally desktop.

But if i go into retroarchs settings > video> and turn on “threaded video” it will make my menu flicker like its in interlaced mode and any rom on any core will launch and switchres works and super res works.

The problem is… next time I open retroarch the menu is in progressive again even though “threaded video” is still on. But if I toggle it to off - my menu will flicker like its in interlaced mode again and will lauch any rom fine again.

Retroarch is starting up in progressive mode and i need it to start in interlaced for it to work. Or at least this is the symptom im seeing and can replicate a fix if I toggle “threaded video” every single time.

Maybe this will help someone more knowledgeable figure out whats going wrong in my setup.

Someone else at arcade controls forum has the same issues ive been experiencing…,162333.msg1711117.html#msg1711117

1 Like

Ive finally figured out what was going wrong. I noticed anytime retroarch would start in progressive 60fps … nothing would play, and if I could trick it into interlaced 30fps by toggling “threaded video” then any rom would load fine. Ive tried changing video_refresh_rate to 30 in cfg file but it was just like toggling “threaded video” and would only work once and next time RA was launched it would revert back to 60fps and whenever RA would start in 60fps mode everything would mess up. I finally tried turning save_on_exit to false in the config…

Now retroarch runs fine everytime, and loads all roms/cores without issues.

Untill… Im in bigbox , then I get a scrambled screen. I dont understand what bigbox could be doing to make the screen scrambled when retroarch runs fine now when launched directly.

I feel like its something to do with retroarch being able to switch resolutions fine on its own but when ran through bigbox it gets messed up. Do I need to run the crt at a specific resolution since it seems bigbox just takes whatever resolution the monitor its on is ran at? Ive tried 640x480 30hz interlaced, 60hz interlaced, 120hz interlaced and all give me the same out of sync image when a games loaded through bigbox. I think once when I set crt to 60hz interlaced the game would load but it wasnt in 240p super res it was in mushy 480i. Ive tried setting descktop res on crt to 2560x240 but just get a squished image but its there and isnt out of sync.

Ive been sitting at this computer for over a week now in ocd mode, i just need it to work so i can do other stuff in life lol. Im desperate…Is crt switchres wizardry noone knows about?

1 Like

Heres a video I feel like its something simple im overlooking.

Ive changed every setting in retroarch config one by one that I thought would have anything to do with it but nomatter what its like this when ran from bigbox but fine when ran from retroarch. Im pulling straws at this point.

Does it work if you launch from a regular command line? That is, just like Bigbox would, but without it?

My commands arent working…do i need to enable debug or something?

So I installed another fresh instance of launchbox on my c drive (not my 8tb launchbox drive ive been having the issues with)

Pointed it to retroarch and bam… 240p first try.

The problem is I spent weeks compiling my 8tb drive from roms I had on my arcade cabs hdd, and roms from another computer. I just recently compiled it all a few months back and its updated to latest launchbox. I pointed to the same retroarch folder as the instance of launchbox I just downloaded and the launchbox I just downloaded outputs 240p fine but my compiled hdd dont. What could be the issue? What would be the best way to fix it without having to recompile/reconfigure the 8tb drive AGAIN from scratch?

I finally- after weeks of troubleshooting- got everything launching in 240p as it should. Through countless guides Ive read, and after posting my issue on a dozen forums, I never seen mentioned that you must go into retroarch/config folder and edit each cores config file to turn on crt switchres…but thats what fixed it.

Hmm, nothing mentions it because it shouldn’t be necessary unless you’re using a completely separate config file for each core. The normal, expected process is to use one global config where you can put that option and then cores only have overrides that change the handful of options that need to differ from the global config.

Regardless, I’m very happy to hear that everything’s working on your end. I’m sorry I wasn’t able to help more.

you probably used the save core overrides funcion for all the cores, this function is an actual nightmare, you didn’t find anything because people setting crt emu driver don’t use save core override

how do i disable or make sure im not using it from here on out?

In settings > configuration, there’s an option to ‘load override files automatically’ (this is an advanced setting, so you may need to go to settings > user interface > show advanced settings ON first). It defaults to ON but you can turn it off to stop loading them.