Retroarch window not movable and borderless on Fedora 34 using Wayland

I am having a weird issue with Retroarch on a new install. I moved over to Fedora 34. It installs fine and appear to be working well aside from one huge annoyance. Retroarch is in a borderless immovable window. I can’t seem to even click on it as a window. It’s as if it is built into the background wallpaper. I have tried to uninstall and reinstall. I have tried to uninstall and install the snap. Restarted machine. Reset defaults. Nothing seems to work. It is the only program / app doing this on the system. Anyone have any ideas?

Are you using X or Wayland? If Wayland, can you try X? You might also check out the AppImage build from, though you lose the nice auto-updates of the snap

From what I understand it is Wayland. I didn’t even know I had a choice with F34. LOL

What is the output of retroarch --features ? Which version did you use the one from Flatpak ? Fedora ?

But it seems both enabled Wayland.

I made a quick test with Fedora 34 and indeed the window is border less but you can move it, if you hold Left Alt key.

If you need it, you can enable Windows companion in Main tab > Show Desktop Menu