RetroArch with CRTSwitchRes on Raspberry Pi

retroarch

#21

We usually compile it on Ubuntu 16.04 but other Linux distro should be fine.


#22

I found out my issue. I was trying to compile the depreciated Lakka source oops.

This is my current error.

make[1]: Leaving directory ‘/mnt/8c026599-057d-4201-8616-ab6cbff6593e/lka/build.Lakka-Generic.x86_64-2.1-devel/xf86-video-intel-028c946/.x86_64-libreelec-linux-gnu’ xf86-video-nouveau: no package.mk file found Makefile:27: recipe for target ‘image’ failed make: *** [image] Error 1

The folder and package.mk do not exist. any ideas?


#23

Yes, indeed xf86-video-nouveau package does not exist. So we have to create one or use nvidia driver by replacing nouveau by nvidia in Lakka options for i386 and x86_64.


#24

@vudiq made some X11 enabled build for testing currently for x86_64.

If needed the commit.

Please let us know if everything is working correctly.

Thank you.


#25

Ok so my finding so far are not good news.

I have tested with my modifications first. Lakka boots, you see the boot image but then you just see a black screen. It has not crash, when you press the power button the lakka logo flash up and the PC turns off.

I downloaded the pre built IMG from the link you posted and I get exactly the same problem.

I’ve tested with 3rd gen Intel, ati HD series and nvideo GT series GPUs. All have the same outcome. So I’m not sure if I am missing something or weather currently the x11 driver only supports specific GPUs. Maybe Retroarch is not initializing the display server correctly.

Any Ideas? Or would it be better if I speak with @vudiq.


#26

Hi,

Yes indeed it seems RA got a segfault when booting. The time we fixed the issue please boot with live ssh if you have ethernet link then connect to your station then stop and relaunch RA with systemctl stop retroarch and retroarch --menu --verbose to get some direct output log.

Thank you.


#27

Ok so finally some good news, kind of.

So the findings are that Retroarch is stuck in a boot cycle where it’s failing to load. However, when I run the commands to force exit Retroarch then manually relaunch it, it loads fine!

Also CRT swithres does work with some odd issues. This is probably related to the x11 setup and configuration.

I’ve read through the verbose output and everything seems fine. The is the same for my img and @vudiq s img too. There are no errors of any kind! (failed to load nothing)

I will get a video uploaded soon and I’ll post the verbose output too.

So the question is, why when you launch Retroarch manually does it load? But it will.not load on Lakka boot?

Is it possible to boot Lakka in verbose mode?


#28

@gouchi Here is the verbose output

https://pastebin.com/dv5K44G6

For some reason it posted half at the top. So ignore that and read down from line 74


#29

Thank you for the log.

You can try to boot with live debugging which will show some output.

You can check also the log with journalctl | grep retroarch

We may have to change a little retroarch.service like l.3 with xorg.service or xorg.target instead of graphical.target. Same for l.5.


#30

Ok cool, I’ll try these steps out at some point in the week.


#31

@gouchi So neither changed worked. However, using xorg.target did seem to change things a small amount. No difference visually but the it does seem that the HDD drive access seem to finish as if it was fully loaded.


#32

Any update to this? I currently have it working with retropie 4.4 with 2560x240p and it looks great using the display Manx video driver.

Was wondering if crtswitchres might perform better and provide native refresh rates?


#33

Hey bro! All right? Well, I was seeing some of your answers and I saw that you understand the program. I’m having a small layout / interface problem. My Retroarch is like on android. But I use it on Windows. I do not know how to undo this. Would you kindly help me?


#34

settings > driver > menu. Change it from “glui” to “xmb” or “ozone”