Saturn Kronos core crashes on save state?! (Help!)

Hi there, long time lurker, first time posting.

I just wanted to confirm that Kronos and Yaba also do this to me 100% of the time with Retroarch (just updated to 1.9.5 to see if it would help, to no avail). As soon as I try to save, the whole emulator shuts down. My specs are Alienware M17 R3, 10980HK, 32GB Ram, Nvidia 2080S, 2TB SSD, Win 10 20H2.

All I have done is install the default retroarch and have downloaded some cores… This is an extremely fresh install as I got this computer on a Dell blowout so I’ve literally only had it a couple weeks and haven’t used Retroarch much at all yet.

So, three of us have confirmed the issue here and one has no issue. What we need to find is what us three have in common that is causing it and where our setups may differ from the user that can even enable rewind! WOW! That instantly crashes the emulator here too.

I’ll do whatever I can to help. I am not super savvy with Windows, as I am coming from 20 years on Apple computers, but I’ll try my best.

Bavanity, just curious do you have any standalone versions of Kronos and Yaba emulators already installed on your computer?

I do have Yaba Sanshiro standalone installed as I find it crashes less than the libretro core. I also wanted to experiment with the latest Vulkan update but find it quite buggy. Not that it really matters as Nvidia OpenGL is very strong, unlike AMD (in windows I mean). I didn’t bother with Kronos as the last version I can find is 2.15 and a few months old, and the core is updated much more frequently.

A friend of mine has an Aorus gaming laptop, also running windows 10, and he has problems with both Kronos standalone and Yaba when assigning controls sometimes. It just doesn’t work or won’t allow trigger assignment for 3D control pad. Or you click on a control to assign and it won’t wait for an input to it’s impossible to assign. If you fluke it once, be happy and don’t do it again LOL. I am experiencing the exact same issue on Yaba standalone so haven’t bothered with Kronos. I mean if more than one person experience identical issues, it’s usually something that can be fixed. I am using an xbox one controller.

PS re rewind, it works fine on beetle saturn and mame/final burn neo.

Some clarification about my previous statement, i can enable rewind, it won’t crash, but it won’t work properly either, afaik rewind/runahead/netplay can’t with hardware-rendered cores.

I’m always using a default retroarch config for my tests, meaning i delete/rename retroarch.cfg before doing my tests.

Try uninstalling your Yaba Sanshiro standalone emulator and then try the Retroarch yaba core. Maybe when you make a save state in retroarch Yaba it’s conflicting with the standalone Yaba emulator already installed.

That was installed far after. Sorry for the late replies, it has been bedlam here and I have been unwell.

I have tried so many things since the post. A fresh reinstall of windows… A fresh install of retroarch in default folder, a fresh install of the manual retroarch into the documents folder which would have absolutely no write permission issue (but if it was that in any case, other cores wouldn’t rewind). Ps1 rewind is no issue either (beetle PSX HW).

I even installed just retroarch and downloaded kronos core, installed saturn bios into system folder, NO other cores or bios, nothing else at all, and it crashes as per always. Playing games in kronos works fine.

Absolutely no standalone kronos or yaba sanshiro on this fresh windows install.

heck, I can even rewind in flycast, no jokes. It’s slow but it works.

The problem is that rewind works via save states, and save states just won’t work for me with kronos…not that I’d ever want to rewind in it, if I really wanted to do that I could use Beetle Saturn, but the point is that save states themselves crash 100% of the time.

I even didn’t install bitdefender this time and am using default defender only, in case it was that!

I don’t know what else to try.

That’s crazy! What could be causing this?

Do you have an Nvidia graphics card? Because that’s what I have. Maybe it’s something Nvidia just can’t recognize or handle for some reason…?

Yes, a 2080 super. I tried both the studio ready driver and game ready driver. Maybe that’s it! Is BarbuDreadMon on AMD? That might answer it!

No, i’m using a nvidia gpu.

Well that settles that… what version of windows specifically? This might be the variable involved.

Retroarch 64-bits on Windows 10 pro 64-bits. It works too on linux which is what i use the most so i’m skeptical about the fact it’s OS-related.

No I am asking the specific windows 10 version. Thanks but I guess I didn’t explain it correctly, sorry.

For example I am on Windows 10 Pro 64 also, but… “version 21H1”… that is the very latest, with all windows updates done also, and I am wondering if it breaks something with retroarch.

I just did a completely fresh install again, this time I left everything default, the 64 bit installer (are you using retroarch 64 bits also or 32 bits?) c:retroarch

Crashes instantly when trying to save only in kronos. I can rewind and save states in every other emulator right up to flycast.

I am using a bluetooth controller so next I will try use a wired and see if that makes any difference. I am trying to think of any variable.

What is your precise install location?

Maybe a screenshot of your Kronos option page?

for all we know it could be even a bios version discrepancy… But as I said, every game that is compatible with Kronos PLAYS perfectly. Only saving is the issue.

I suppose I’ll have to work around it with native game saving but it’s so not the same thing… I’ll need to complete levels and find save points etc to do that, where as I would love to be able to save on the fly.

I appreciate your replies.

PS I just noticed you are testing with Panzer Dragoon Saga… I don’t own that game so can’t legally (and won’t) test it… I am now wondering if it’s specific games that work and others that don’t.

I can tell for sure that i’m not using latest version since i rarely use windows and actually blocked those forced updates. I wouldn’t be able to say the exact version though, and i don’t plan on booting windows anytime soon. But again i really doubt OS matters.

I always use the portable zip, not the installer. FWIW, i would be only half surprised if some settings were carried over from older installation when using the installer. And i use the 64-bit one as already said.

FWIW, i’m always using wired controllers.


As said several times, i’m always using default settings on a fresh install for my tests. Basically i download latest nightly, uncompress it, copy bios from old setup, launch it, download core from online updater, then launch my game (redump cue/bin format).

I’m using the bios from 1st gen japan console, but i doubt it matters for savestates.

I used that one because the original report was about it.

To my great sadness, especially seeing how much it costs now, i lost that game long ago (more like someone probably stole it from me). I really hope it gets a remake someday.

Thanks for your reply. I just tried the zip 64 download in E:/emulators/retroarch Same crash. (it’s an external samsung t7 ssd drive with my roms on it).

It’s probably a windows thing, that’s what is making the most sense it seems.

However you say you don’t know the exact version of windows, all you do is press windows key, type the word “about” and you will see “about this pc” option. Click on it and it will tell you the exact version of Windows. So if you are saying that save states work for you in Windows Kronos, even if you don’t boot into win10 often, please just check next time you do, it will take a few seconds. I am not asking you to boot into windows to check this specifically, but rather asking when next you happen to boot into windows anyway, to please check.

I am finding it very unlikely though that this isn’t something that the author has to fix in the emulator, as there is more than one person reproducing it. A friend of mine will be testing it over the weekend for me, so that will be interesting to see and I will report when I hear from him.

Anyway, the Kronos guy told me that there’s a bit of a hiatus on updates for it right now and that the author will get back to it at some point soon… Apparently it’s been months since a real update. I’ll direct him to this topic and hopefully he can reproduce it and fix :slight_smile:

Yes, François is currently busy irl, but anyway all libretro matters are handled by me for that project.

Could you try turning off Settings > Saving > Save State Compression on your setup ?

Hi I just did that, it didn’t work. Still crashes immediately upon save state :frowning: I didn’t realise you were the developer for the libretro Kronos core. Sorry about that.

I’m using Windows 10 Home version 20H2 . Here are my specs:

Intel® Core™ i7-8750H CPU @ 2.20GHz 2.20 GHz

32.0 GB (31.9 GB usable)

64-bit operating system, x64-based processor

With high performance Nvidia processor/graphics card.

Still crashes every time on save state.

FWIW, yesterday i noticed RetroArch is forcing the Kronos core to make 4 calls in a row to its saving state function everytime it requires a savestate (it’s asking 3 times the size consecutively :thinking: and i can’t tell the size without actually making the savestate, then it’s asking me for the actual savestate). I wonder if that non-trivial amount of operation isn’t responsible for your crashes, especially since that function is internally using a tmp file (so something saved on disk in some system tmp folder i guess) every time it is called.

I’ll see if something can be done to make that code a bit less crazy.