1.7.7 - Some Issues

First of all, I’m astonished with this version, the interface is tidier, we now have Retroarchievements badges showing on-screen, all other on-screen messages are widgets as well.

I went ahead and started from scratch, moving all older RA files to another folder, set GLcore and updated all slang shaders (probably unneeded), configured some hotkey inputs, shader and overlay.

Everything but the shader is working fine, I mean, it loads the config and the log files says it located the shader preset if I save a preset for it, but I also tried using it universally. But the shader only actually loads when a game starts if I manually go into the menu and hit apply in the shader settings.

I’m not sure if this log will help, the slang info down below is probably when I hit manually the apply button.

The other issue I’m having is about the new widgets, info, cheevos badges, etc., since a lot of people use overlays, it covers them, I tried moving them in the appearance options, but those values won’t work for widgets, only text I think. I realize it was asked or suggested, but would be nice to have them displayed over the PNG overlays, moving them also solves it, but how?

[INFO] Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 SSE4 SSE4.2 AVX AES [INFO] Built: May 6 2019 [INFO] Version: 1.7.7 [INFO] Git: e8c9a272ee [INFO] ================================================= [INFO] Loading dynamic libretro core from: “R:\Hyperspin\Emulators\RetroArch\cores\fbalpha_libretro.dll” [INFO] [Overrides] no core-specific overrides found at R:\Hyperspin\Emulators\Retroarch\config\FB Alpha\FB Alpha.cfg. [INFO] [Overrides] no content-dir-specific overrides found at R:\Hyperspin\Emulators\Retroarch\config\FB Alpha\MAME.cfg. [INFO] [Overrides] no game-specific overrides found at R:\Hyperspin\Emulators\Retroarch\config\FB Alpha\chasehq.cfg. [INFO] [Shaders]: preset directory: R:\Hyperspin\Emulators\Retroarch\shaders\presets [INFO] [Shaders]: Specific shader preset found at R:\Hyperspin\Emulators\Retroarch\shaders\presets\FB Alpha\FB Alpha.slangp. [INFO] [Shaders]: core-specific shader preset found. [INFO] [Remaps]: remap directory: R:\Hyperspin\Emulators\Retroarch\config\remaps [INFO] [Remaps]: no game-specific remap found at R:\Hyperspin\Emulators\Retroarch\config\remaps\FB Alpha\chasehq.rmp. [INFO] [Remaps]: no content-dir-specific remap found at R:\Hyperspin\Emulators\Retroarch\config\remaps\FB Alpha\MAME.rmp. [INFO] [Remaps]: no core-specific remap found at R:\Hyperspin\Emulators\Retroarch\config\remaps\FB Alpha\FB Alpha.rmp. [INFO] Redirecting save file to “Z:\Retroarch\saves\chasehq.srm”. [INFO] Redirecting savestate to “Z:\Retroarch\states\chasehq.state”. [INFO] Environ GET_LOG_INTERFACE. [INFO] Content loading skipped. Implementation will load it on its own. [INFO] CRC32: 0x9deeb81 . [libretro INFO] Setting save dir to Z:\Retroarch\saves [INFO] Environ SYSTEM_DIRECTORY: “R:\Hyperspin\Emulators\Retroarch\system”. [libretro INFO] Setting system dir to R:\Hyperspin\Emulators\Retroarch\system [INFO] Environ SET_CONTROLLER_INFO. [INFO] Environ SET_VARIABLES. INFO] Environ SET_VARIABLES. [INFO] Saved core options file to “R:\Hyperspin\Emulators\RetroArch\retroarch-core-options.cfg” [libretro INFO] [Cheevos] System RAM set to 000000000CB5B040 196608 [INFO] Environ SET_ROTATION: 0 [INFO] Environ SET_PIXEL_FORMAT: XRGB8888. [libretro INFO] Driver chasehq was successfully started [INFO] Skipping SRAM load… [INFO] Version of libretro API: 1 [INFO] Compiled against API: 1 [INFO] [Audio]: Set audio input rate to: 47952.05 Hz. [INFO] [Video]: Video @ fullscreen [INFO] [GLCore]: Found GL context: wgl [INFO] [GLCore]: Detecting screen resolution 1920x1080. [INFO] [RCHEEVOS]: testing NES (discards header) [INFO] [RCHEEVOS]: testing Generic (plain content) [INFO] [WGL] extensions: WGL_ARB_buffer_region WGL_ARB_create_context WGL_ARB_create_context_no_error WGL_ARB_create_context_profile WGL_ARB_create_context_robustness WGL_ARB_context_flush_control WGL_ARB_extensions_string WGL_ARB_make_current_read WGL_ARB_multiṡÙ[INFO] [WGL]: Adaptive VSync supported. [INFO] [WGL]: wglSwapInterval(1) [INFO] [GLCore]: Version: 3.2.0 NVIDIA 417.35. [INFO] [GLCore]: Using resolution 1920x1080 [INFO] [XInput]: Found XInput v1.4. [INFO] [XInput]: Found controller, user #0 [INFO] [XInput]: Pads connected: 1 [INFO] [DINPUT]: Enumerating joypads … [INFO] [DINPUT]: Device #0 PID: {028E} VID:{045E} [INFO] [DINPUT]: Done enumerating joypads … [INFO] [XInput]: Attempting autoconf for “XInput Controller (User 1)”, user #0 [INFO] [DINPUT]: Found XInput pad at index 0 (DINPUT index 0) [INFO] [XInput]: Found VID/PID (045E/028E) from DINPUT index 0 for “XInput Controller (User 1)”, user #0 [INFO] [Joypad]: Found joypad driver: “xinput”. [INFO] [GLCore]: Loading stock shader. [INFO] [Autoconf]: 127 profiles found. [INFO] [slang]: Building pass #0 (N/A) [INFO] [slang]: Reflection [INFO] [slang]: Textures: [INFO] [slang]: Source (#0) [INFO] [slang]: [INFO] [slang]: Uniforms (Vertex: yes, Fragment: no): [INFO] [slang]: Push Constants (Vertex: no, Fragment: no): [INFO] [slang]: MVP (Offset: 0) [INFO] [slang]: [INFO] [slang]: Parameters: [INFO] [GLCore]: Not using frame history. [INFO] [GLCore]: Not using framebuffer feedback. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Video]: Found display server: win32 [INFO] Found shader “R:\Hyperspin\Emulators\Retroarch\shaders\retroarch.slangp” [INFO] [XAudio2]: Requesting 64 ms latency, using 64 ms latency. [INFO] [Autoconf]: selected configuration: R:\Hyperspin\Emulators\Retroarch\autoconfig\xinput\XInput_Controller_User_1.cfg [INFO] [Menu]: Found menu display driver: “glcore”. [INFO] [RCHEEVOS]: got game id 0 [INFO] [RCHEEVOS]: testing Generic (filename) [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] Environ SET_SUBSYSTEM_INFO. [INFO] [Menu]: Found menu display driver: “glcore”. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [LED]: LED driver = ‘null’ 0000000000AB03C0 [INFO] [MIDI]: Initializing … [INFO] [MIDI]: Input disabled. [INFO] [MIDI]: Output disabled. [INFO] [MIDI]: Initialized “winmm” driver. [INFO] Environ SET_INPUT_DESCRIPTORS: [INFO] Loading history file: [R:\Hyperspin\Emulators\Retroarch\content_history.lpl]. [INFO] Loading history file: [R:\Hyperspin\Emulators\Retroarch\content_favorites.lpl]. [INFO] Loading history file: [R:\Hyperspin\Emulators\Retroarch\content_music_history.lpl]. [INFO] Loading history file: [R:\Hyperspin\Emulators\Retroarch\content_video_history.lpl]. [INFO] Loading history file: [R:\Hyperspin\Emulators\Retroarch\content_image_history.lpl]. [INFO] [GLCore]: VSync => on [INFO] [WGL]: wglSwapInterval(1) [INFO] Written to playlist file: R:\Hyperspin\Emulators\Retroarch\content_history.lpl [INFO] [RCHEEVOS]: got game id 12061 [INFO] [RCHEEVOS]: got achievements for game id 12061 [INFO] [RCHEEVOS]: Load task finished [INFO] [GLCore]: VSync => off [INFO] [WGL]: wglSwapInterval(0) [INFO] [GLCore]: VSync => on [INFO] [WGL]: wglSwapInterval(1) [INFO] [GLCore]: VSync => off [INFO] [WGL]: wglSwapInterval(0) [INFO] [GLCore]: VSync => on [INFO] [WGL]: wglSwapInterval(1) [INFO] [GLCore]: VSync => off [INFO] [WGL]: wglSwapInterval(0) [INFO] [GLCore]: VSync => on [INFO] [WGL]: wglSwapInterval(1) [INFO] [GLCore]: VSync => on [INFO] [WGL]: wglSwapInterval(1) [INFO] [Font]: Using font rendering backend: freetype. [INFO] [Font]: Using font rendering backend: freetype. [INFO] [config] Saved new config to “R:\Hyperspin\Emulators\RetroArch\retroarch.cfg”. [INFO] Content ran for a total of: 00 hours, 00 minutes, 07 seconds. [INFO] Unloading game… [INFO] Unloading core… [INFO] Unloading core symbols… [INFO] Saved core options file to “R:\Hyperspin\Emulators\RetroArch\retroarch-core-options.cfg” [INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

2 Likes

I can confirm the same issues with slang shaders and the GLcore video driver.

4 Likes

Yeah it’s definitely a bug in the new OpenGL Core driver. I’ve switched back to the old OpenGL driver for now.

Thanks for the report, we’ll see if we can get a fix in real quick.

1 Like

I can’t reproduce the shader thing at all. Try explaining the issue with steps to reproduce.

Shader presets are working fine for me at least

Load core, load game, pick slang shader preset and save a core preset, close Retroarch. Load game that uses the same core via command line through another frontend and the game loads without the preset though when you go into the Quick Menu > Shaders all the shader passes are there but no shader effects are shown. Double checked the default video driver is set to GLcore and it’s also set to GLcore when the core is loaded. I used the GenesisGX core for my testing.

It’s working fine for me.

nvm I don’t use launchers

I’ve set a default shader (an edited version of crt_aperture) in the retroarch.cfg:

video_shader = ":\shaders\default_crt_shader.glslp" (<- changed to a .slang shader for the new driver)
video_shader_enable = "true"

The default shader is loaded every time, if no specific core config file can be found.

But with the new “OpenGL Core” driver, this method no longer works.

Yeah it seems to be an issue when loading a core via command line, loading a game through the RA GUI such as the History tab it loads the shader fine. This only happens with the GLcore video driver, the old GL driver does not have this issue.
I tried it with the GL driver and a GLSL shader, no problem. Tried it with Vulkan and DX12 with a slang shader and also works fine.

1 Like

Do you think it would be possible to display the widget over the Overlay?

Yeah I forgot saying I am using RocketLauncher which sends command lines to RA, anyway, I switched to Vulkan and everything is working fine, loading the shaders, etc.

Yeah, these seem to just be bugs with the GL_core driver, so we’ll get those worked out and it should be good.

2 Likes

@hunterk

Hi!

Has it already been fixed?

Thanks.

for at least some of the drivers, yeah.

Hi @hunterk, what do you mean by “some of the drivers”? Fixed for some gpu vendors only, or do you mean something else?

With GLcore + frontend (LaunchBox) the shader preset doesn’t load…

@cubatilles it means that it’s fixed for GL and Vulkan. The other RetroArch video drivers will need to be fixed separately:

@lfan which preset(s)? All of them? Can you post a log?

I saved the core preset for shader, but RetroArch doesn’t load the file when I run the core via LaunchBox. It’s only with GLcore driver.

Correcting: the preset is loaded but not applied.

Still the same as you stated, I was using Vulkan, which loads the shader presets fine, but with this video driver, the content isn’t running smoothly, horizontal scroll stutters, while GLcore is smooth, but won’t apply the shader preset automatically via CLI.

Edit: I have fixed the stuttering with Vulkan as I mentioned above by running DDU (Display Driver Unninstaller) in safe mode and refreshing the GPU driver, the problem was totally on my end.