1.78 - Handheld - Game & Watch Crash on Android

1.78 - Handheld - Game & Watch Crash on Android,

I am using poco f1 phone…

Works OK on Windows X64.

Anyone else ?

Just me ? anyone else ?

Can confirm, Game & Watch no longer working on Android. RetroArch 1.7.8 using the latest files from the “Handheld Electronic Game” folder from the BuildBot. Samsung Galaxy Tab S5e, 4 GB Ram. Worked on previous versions of RetroArch, but I’m sure it’ll be fixed in time. :slight_smile:

I hope too…

Tested on Poco f1 and Galaxy Tab S4

The problem in the core or in the new RA version ?

So I also have an Amazon Fire HD 10 with the 1.70 version of RetroArch. Game and Watch works correctly on this version. Once I get home from work, I’m going to point the update folder in the Fire HD 10 to the same one used in the 1.78 version of RetroArch on my Samsung Galaxy Tab S5e to determine if it’s the core or if it’s RetroArch itself that is causing the issue. I’ll update with results this afternoon.

It’s the Game & Watch core that’s the issue. Updated that specific core in RetroArch 1.7.0 and it no longer works. I had just tested it seconds before updating the core and played some Donkey Kong (Coleco) without issues, then after the core update, it wouldn’t start up. However, I noticed that I can still ‘exit’ out of the screen using the ‘Menu Toggle Combo’ that I set for my Bluetooth Controller. The core doesn’t crash RetroArch, it just won’t start up any of the games.

I just altered the “Buildbot Cores URL” in “Network”, “Updater” settings to: http://buildbot.libretro.com/nightly/android/2019-05-05_cores/arm64-v8a/ saved the config - exited out of RetroArch - went back in and updated only the Game & Watch core via Online Updater and it’s all good. Also, don’t forget to clear the URL settings afterwards in order to stay up to date with the latest cores. :wink:

Thanks!

I will try later…

Didn’t checked this yet, But it should be fixed also on the latest version

Well, currently I’m using the 05/05/19 version of the Game & Watch core on a 1.78 version of RetroArch. If I update the GW core with the latest nightly, I’m not sure it’ll continue working…

Still Not working on 1.79 :frowning_face:

Still Not working on 1.81 :frowning_face:

Just me ? or now one cares for handheld games anymore ?

The issue’s been reported on the “gw-libretro” GitHub (https://github.com/libretro/gw-libretro/issues/52) since July. I guess no one cares for handhelds, like you said.

I would very much rather use this core for handheld emulation rather than M.A.M.E. Also, I’m not entirely sure if these specific games are also available on the M.A.M.E. core either.

Sad, really. But I’m still hanging on to hope that this core will be ‘reverted’ or the issue ‘fixed’ at some point in the future.

1 Like