2 gamepads / binding


#1

Hello,

i have a problem with retroarch 1.5 on android: i try to use 2 logitech USB gamepads. It works not on all android devices. For example on my galaxy tab 3 it works:

  • input user 1 binds says device index: Logitech Logitech® Precision™ Gamepad (#1)
  • input user 2 binds says device index: Logitech Logitech® Precision™ Gamepad (#2) -> so on my galaxy tab it works.

but on my surftab breeze it seems like retroarch thinks both gamepads are the same ?

  • BOTH input user n binds says device index: Logitech Logitech® Precision™ Gamepad (not #1 or #2 !!!)
  • BOTH gamepads behave like it’s #1

I use the same gamepads - and the same USB hub! You might think it’s hardware related of tablet ? Now: on this table N64 and SNES emulator work - with both gamepads.

any idea ?


#2

Just go into settings > input > p1 or p2 input binds and change the device index so they’re not the same and it should work.


#3

hello, thank you for the answer. But how should i change this ? When i click on “User 1|2 Device Index” nothing happens.

Anyway: i did a re-installation from scratch in the meanwhile. I don’t know what’s different this time - but this time it works! I already tried SNES emulation with 2 gamepads -> works.

But what i actually wanted to have is a AMIGA-emulation with 2 USB-gamepads. Retroarch seems to be the only AMIGA-emulator on android that supports 2 gamepads (at least as far as i know). I couldn’t get this P-UAE running yet. When i run P-UAE i configure kickstart.rom and ADF-floppy files as usual. But when i start the emulation i only get a black screen, and Retroarch freezes. I tried some other AMIGA-emulators on this tablet - they all work - but they don’t support 2 gamepads.

any idea about this P-UAE - problem ?


#4

http://lindqvist.synology.me/wordpress/?page_id=182

The guide above should help you get running Not sure about 2 gamepads though


#5

I checked the 2 gamepads again. like i said: on my surftab breeze the binding just says: Logitech Logitech® Precision™ Gamepad (not #1 or #2 !!!)
I think it actually says #1, #2 or similar - i just cant’ see it on this small 7" screen - this text is to large - it’s cutted.

can i somehow make the retrocarch font smaller to see the whole text ?


#6

Hello

I have 2 gamepad, I can not configure them in retroarch, I can detect them as a single gamepad, what can I do? These gamepad https://es.gearbest.com/game-controllers/pp_424407.html

Thank you


#7

Have you tried going into settings > input > p1 (or p2) input binds and changing the device index to one of them to use the other controller?


#8

HELLO! I enter the device index and I only see a gamepad, they are both well linked but being the same brand and model only appears a gamepad, I do not know what to do … Thank you


#9

If they’re identical controllers, there should be two entries for them in the device index, though it’s difficult to tell which one you’re choosing (since they show up with identical names).


#10

Hello! As you can see, two controls are connected and synchronized, but only one appears …