8bitdo (SF30 Pro) Controller with playstation emulator?

Hi all,

I need to test this on windows to see if it is the same but, on my nvidia shield everything works with my controller, other than playstation. I have tried both cores, and disabled multi-tap, but the controller inputs do not work at all. I can use L3+R3 to open the quick menu, but it looks like the emulator just doesnt recognise the controller. It is paired as SF30 Pro controller, and seems to be the same for both x and d input.

Any ideas?

Which game(s) have you tried? You may need to change the emulated device type from dual shock to normal controller (or vice versa) for some games.

I’ve tried about 4 and have tried changing it from retropad with analogue and without. It doesn’t seem to make any difference

For what its worth…i have the same issue since updating to 1.9.2 (and above)…

Works perfect in SNES9x, PCSX2, PicoDrive…but no way to make it work in BeetlePSX, ReArmed or BSNES.

System:

Windows7 64bit, i5 3570K

CRTEmuDriver -> UMSA -> Philips Consumer CRT (I can’t figure out how to use the new CRTRes that does not need the CRTEmuDriver anymore)

It might be a problem with write protection of the Retroarch.cfg file…it does not show write protection when i go to properties of the file in windows but notepad++ tells me it has one…is there a hidden write protection setting in Retroarch for the Retroarch.cfg file that got implemented recently?