A question about Skyward Sword

Is it possible to play Legend of Zelda: Skyward Sword, in RetroArch?

I have both a real Wiimote with Wii Motion Plus built in, and a Mayflash Dolphinbar, but I’m not sure how to get it working in RetroArch.

I’ve never tried it, but I think it should work. You have to bypass RetroArch’s input system and sync directly to the core. Though I’ve not done such a thing myself I know it’s possible.

1 Like

How do bypass RetroArch’s input system and sync directly to the core?

I’ve done this! It’s been a minute since I’ve set it up though… I’m gonna try setting it up tonight and report back.

I know I had to use a dolphin bar to get bluetooth to properly recognize my wiimotes - but I think that’s a case-by-case thing, even with stand-alone dolphin. You might be able to just use your internal bluetooth. I also know there are some kind of “toshiba stack” drivers you can use for internal and external bluetooth recievers but I’ve never used those.

Anyway, I know once I had the initial setup going, whenever I launch RetroArch I would just hold down 1 and 2 and the controller would sync right up and play.

Like I said, I’ll give it a go again tonight - it’s just been a while since I’ve tried it.

1 Like

Ok, so I got it up and running. Here’s my full setup.

  • Mayflash Dolphin bar in “Mode 4” .
  • Press “Sync” on both Dolphin Bar and WiiMote to pair up.
  • In RetroArch, set your controller type in Quick Menu>Controls to “Real WiiMote”.
  • Save Core Remap to keep this setting.

Now, whenever you launch Dolphin, all you have to do is press a button on the WiiMote to wake it up, you will see the light on the controller show you as Player 1, and it will give a quick vibrate to let you know it’s all setup.

That’s it. That’s all you have to do.

As a total side-note, my Dolphin Bar’s infared LEDs are completely shot, which is apparently an extremely common problem. I honestly just tuck the thing behind my PC and use it purely for connecting the WiiMotes. I have a legit wireless sensor bar from Nintendo that I use on my actual Wii and Wii U, I just turn that on and it works fine.

Of course you can always just setup 2 tea-light candles as well. I’ve used that in a pinch. Just a thought for anyone who doesn’t have any kind of sensor bar, but can connect via internal bluetooth or something I guess.


Thanks! I’ll give this a try!

A bit off-topic, but the latest Dolphin supports DSU protocol, so you can play Skyward Sword with Joy cons. I tried it out using BetterJoyForCemu, and it worked quite well. Is this also possible in RetroArch?

1 Like

:open_mouth: :open_mouth: :open_mouth: :open_mouth: I had no idea this was even remotely a ‘thing’.

I’m not sure the last time that the Dolphin core was updated though… My file explorer says I last updated the core on Jan 9th, but that could have just been the last time I downloaded the core.

I thought I had heard somewhere we shouldn’t expect many updates to the core in the near future, but I honeslty don’t know.

If this works though I’m gonna buy a pair of orange Joycons straight up. That’s awesome.

Using BetterJoyForCemu, and RetroArch, I was able to get the Joy cons to work separately, but I’m not sure how to map motion control to the Joy con’s gyro, and I wasn’t able to get past Skyward Sword’s check for Wii Motion Plus. The motion is either mapped to a control stick, or a mouse, and it doesn’t detect Wii Motion Plus.

In Dolphin, Wii Motion Plus is emulated, and I mapped the controls using a profile found in a video on YouTube that explains how to set this up in Dolphin.

I tried doing what you did, but even though the Wii Remote was connected to the Dolphinbar the buttons did nothing.

I tried turning on continuous scanning via the core options, and the Wii Remote vibrated . . . and continued to vibrate every second, or two, and the blue lights on the Wii Remote would flash, and show it as if it was both player 2, and player 4.

I tried messing around with the input settings, disabling different inputs, changing the input drivers, etc . . . nothing I did seemed to work.

It also didn’t matter if it the controls were set to Real Wii Remote, or not.

I’m not sure what’s going on. :disappointed:

I haven’t played with this in a while, so I’d have to completely re-check my settings. If I recall right though, this split-light behavior usually means it’s emulating a keyboard/mouse.

I would try switching up your dolphin bar mode.

The Dolphinbar is set to mode 4.

I tried the other modes, but the controls are unresponsive.

If I disable continuous scanning in the core options, the Wii Remote connects to the Dolphinbar correctly, but it doesn’t vibrate at the games launch, and the controls are unresponsive . . . so it can’t be used.

I made a crappy video below to show what’s occurring when continuous scanning is enabled.