Amiga P-UAE Core


#21

I also did a test running a Classic WB HDD image configured with FS-UAE on the PC and running it with RetroArch P-UAE, and it runs pretty nicely as long as the system specs are kept modest (MC68020EC). The image is loaded with WHDLoad games which are fairly easy to launch through using the controller as a mouse, so no need to configure every game manually on the Retroarch side.

Like you mentioned, P96 will not work, but the normal screen modes including hires overscan work without fuss. Also saving back to HDD image is no go and every change made with settings, installing new software etc gets wiped out with a reset, which makes it a bit harder to tweak the image to my liking.


#22

I found the example HDD mount to be considered “legacy” in the master configuration file and used the following mounts in the .uae, the filesystem2 mounted but the file information was corrupt as i suspect the driver options don’t support windows.

  • use_gui=no
  • cpu_type=68040
  • cpu_speed=max
  • cachesize=8192
  • compfpu=true
  • chipset=aga
  • kickstart_rom_file=C:\Users\adria\AppData\Roaming\RetroArch\system\kick31.rom
  • chipmem_size=4
  • bogomem_size=2
  • fastmem_size=8
  • hardfile2=rw,DH0:C:\Users\adria\AppData\Roaming\RetroArch\roms\Commodore - Amiga\hdf\Amiga1200.hdf,32,1,2,512,1,uae
  • hardfile2=rw,DH1:C:\Users\adria\AppData\Roaming\RetroArch\roms\Commodore - Amiga\hdf\Software.hdf,32,1,2,512,-128,uae
  • filesystem2=rw,PC:PC:C:\Users\adria\AppData\Roaming\RetroArch\roms\Commodore - Amiga\hdf,0
  • gfx_framerate=1
  • gfx_width=720
  • gfx_height=568
  • gfx_center_horizontal=simple
  • gfx_center_vertical=simple
  • show_leds=true
  • joyport0=mouse
  • scsi=true

#23

Hi,

I’m having issue with getting the P-UAE core (2.6.1 a739e45) working in Retroarch (1.7.5) on an Android (4.4) tablet (GPD XD original).

I have put in the relevant roms (with correct MD5 checksum), and rom key, and WHDLoad.hdf (with the roms in Dev/Kickstart) - as suggested by the guides - in to the Retroarch system directory. However, when I load the core and launch the content (an ADF game file - R-Type.adf), I get a blank screen (with the Retroarch button overlays) and then Retroarch crashes/stops.

I’m able to get other cores working (like for NES, SNES cores) OK.

I’ve tried this with various Android devices (Nexus 5 running Android 6.0.1) and a One Plus One running Android 9 but all have the same issue when trying to use the P-UAE core.

On Windows, I can get it to work just fine - using ADF and using HDF files - so I don’t think it is the rom and WHDLOAD.hdf file I’m using.

Any advice would be appreciated. Thanks.


#24

Using a logcat viewer, I see that there is a crash just after RetroArch writes to a playlist file:

12-19 08:59:25.943 I/RetroArch(19520): Written to playlist file: /data/data/com.retroarch/content_history.lpl 12-19 08:59:25.943 F/libc (19520): Fatal signal 4 (SIGILL) at 0x7a15d6a8 (code=1), thread 19539 (com.retroarch)

This crash only occurs when trying to load a game using the P-UAE core. Other cores seem to be working OK.

Is it possible to download and try a previous version of the P-UAE core (for Android ARMv7)?


#25

If of any use to anybody, a pastebin of an example DEBUG logcat for the crash can be found at:

https://pastebin.com/PdwGVJdD


#26

Did you ever get it working? I’m having similar problems.


#27

Nope. Unfortunately, until there is a new version of the P-UAE core (for Android) that fixes this issue, then there will always be this issue.


#28

I got it working. I installed the 64bit version of Retroarch, and then it just worked.

Edit: Well sort of… It only works if my hdf files are in the retroarch dir/system. If I try to load a game from another folder I get system request asking for dh1. If I try to change the Retroarch system dir to say my Amiga hdf folder I just get the purple kickstart animation. Very weird.