Amiga P-UAE Core


#1

Hallo,

When I try to load an Amiga game I only see the “P-UAE Main menu” Screen on my Android device and the game doesn’t start. In the P-UAE Main Menu are several settings Buttons like System, Hard Disks, ROM etc. but it isn’t possible to use them by the touch screen. Does anyone have a manual how to start / play an Amiga game with this core?


#2

You can use the RickDangerous.uae template file from the get repo to configure the game,but this core is currently unusable even though it runs.(For now just use uae4all android)

This emulator is completely free and open source,it is not from stolen source!(I did not make it.) https://play.google.com/store/apps/details?id=atua.anddev.uae4all2&hl=en

And if your device is armv7/8(I also did not make this one.): https://play.google.com/store/apps/details?id=atua.anddev.uae4arm&hl=en


#3

Thank you for your response. I know these other emulators but i would like to use Retroarch to play Amiga Games because I think it is great to play games from different emulators with only one app. The problem is that when the P-UAE core starts i can’t use the touch screen to press the above mentioned buttons and the mouse cursor doensn’t move also. I would be grateful if someone has an explanation how i can start games properly with this emulator.


#4

Unless there have been some recent changes that have broken the functionality of the P-UAE core, you should be able to get it up and running. The trick is to create configuration files for each of your games. You’ll probably need to create the config files on your computer and then transfer them to your Android device to avoid having to edit them directly on your device.

This is the P-UAE core in action:

I’ve written a guide on how to do this on the NVIDIA Shield that you could get some inspiration from: http://lindqvist.synology.me/wordpress/?page_id=182

You should be able to follow the same steps on your device.


#5

That’s a good hint. Do you know when the “broken P-UAE core” will be fixed again so that full functionality is provided? Maybe in the next update of Retroarch?


#6

If you are able to get to the P-UAE main menu screen, then I think the core is working as it should. Try to create a config file for your game based on the instructions in the link I gave and use that config file as the “rom” you load with the P-UAE core.


#7

@diablodiab Thanks so much for writing this guide. I used it as the basis for getting Amiga games to run on the SNES Classic console using WHDLoad -

It’s incredibly difficult to find anything related to running Retroarch P-UAE and yours was the only guide I could find. Unfortunately it doesn’t look to be a well supported or actively worked on core although what is there works surprisingly well.

Hopefully this will spurn someone to help work on it or port over one of the newer Amiga cores. There’s definitely a fan base who would love seeing that happen!


#8

Hi diablodiab

I know this post was a while ago but hopefully you can still help me. I have tried following your guide and downloaded your cfg files and replaced the Retroarch files with them. However when I try to download or update any cores nothing happens. I am not sure if I am doing anything wrong. Hoping you can please assist as the P-UAE core just crashes when I try to launch it. Was hoping you version of the core would fix this issue.


#9

I’ve been able to get this core to work on my Shield TV and S8+ but I did need to download the core from diablodiab’s site not the most current one in the nightly repo. I suggest deleting the core if you already have it and move your core folder to something on the sdcard that you can edit/access with a file browser. Then ether edit your config to point to their cores repo or download it and extract it to the above mentioned core directory. After that I setup uae files as they mentioned pointing to my hdf files and kickstart files.

Also as a side their Hatari core is also the only one I’ve gotten to work.


#10

I’ve a new Nvidia Shield TV with a fresh version of Retroarch installed. For me, loading the P-UAE core through the menu doesn’t even bring up a main screen. I’ve checked multiple instructions to have the exact kick rom files with the right names and MD5 hashes.

When trying to load any content or start the emulator as it is, Retroarch crashes and closes.

I was hesitant to try out the instructions @diablodiab posted since it’s mostly about configuring the games if the emulator runs ok otherwise, but in my case it doesn’t even get to the menu nor the Amiga’s disk insertion screen. Nevertheless I did work out an identical setup with identical files, which only end up crashing Retroarch, like before.

I’ve successfully configured and run Amiga emulators since the early 2000s on multiple platforms, but this one … I just can’t figure out. Someone mentioned a possibility to download and replace the core with a stable one, but I couldn’t find any links to do this.


#11

To replace the P-UAE with the one on diablodiab edit the config file in /sdcard/android/data/com.retroarch/files/retroarch.cfg (remember to back it up) update the line core_updater_buildbot_url so it uses the address “http://buildbot.libretro.com/nightly/android/latest/armeabi-v7a/

after that open retroarch and when you goto update the core it will be the one on his server which I can confirm works on my shield tv and my Galaxy s8+

I would suggest after you download the core you rename the cfg file something else and replace it with your backup so you are able to update the other cores again if needed.


#12

Checked the configuration file and it already points to that URL by default. Maybe this was changed with the newer builds?


#13

I think he meant to say that you can point it to this URL: http://lindqvist.synology.me/shield/

This is where I store the core I refer to in the guide. Just remember to change the URL back when done, so you still get your other cores from the official site.


#14

Yes I did thank you, long day not enough coffee.


#15

Works a treat. Cheers, both!

Edit: Right mouse button with the controller doesn’t seem to be supported, right?


#16

None of the games I played use the mouse so I cant comment on that one.


#17

If I remember correctly, you switch to mouse mode by pressing the select button, which changes A/B buttons to left/right mouse buttons. Select then switches back again.


#18

Just use fs-uae. It has a online database that autoconfigures games (including whdloads, even though those have regular churn so sometimes games ‘disappear’ and ‘reappear’ from the collection if you update the whdloads regularly).


#19

Thanks. I didn’t even know fs-uae existed. But the OP was asking about emulation on Android and there doesn’t appear to be a fs-uae for Android.


#20

Had a bit of a play with P-UAE in RetroArch and generally for emulating games it works quite well after it is setup on a game by game basis.

A couple of points: -The current version of P-UAE that is used by the team working on UAE is 2.61 compiled from GnoStiC source (no longer on github) with an indication they are going to swap to the WinUAE version. See https://github.com/libretro/libretro-uae for details.

  • This version is heavily restricted in comparison to other UAE variant and the configuration options should be taken from the configuration.txt file noting some options like Z3 memory and Graphics card just don’t seem to work. -Some older games could not be loaded using WHDownload due to compatibility / memory issues with the emulated machine however using adf images solved the problem. The example here is Bards Tale noting it may have been ignorance that was the main issue.
  • Have got Classic WB 28 version working noting that the configuration will not support Picasso96, filesystem2 mapping (Created a HDF for Software), required a cfg file to remove all the Retroarch hotkey binds and the P-UAE emulator messes up some keybindings mainly q w a z (verified hdf against WinUAE). -Could not get the current android core to run on the nvidia shield however the same configuration file on Windows worked without an issues. -Emulator Menu did not show the CPU emulation correctly however the CPU type was verified within WB using Scout

As far as setup you need the following files for a WHDownload Game in addition to the WHDownload hdf file with the Kickstart images: .hdf (.slave file renamed to game.slave) in roms/Commodore - Amiga/hdf .uae in roms/Commodore - Amiga/config with the configuration for the emulator.

In addition the following files may or may not be required: .opt in config/PUAE - Contains PUAE RetroArch options (This file is created when saving the options from the RetroArch in game Options menu). .cfg in config/PUAE - Contains RetroArch options eg. hotkey binds

I used the cfg file to remove all the hotkey binds when running WB however I did notice options like viewport are ignored in preference of the configuration within the .uae file.

Anyway it was good fun trying to see what did work and definitely a challenge getting Classic WB running under P-UAE and would recommend using WinUAE etc for WB however for emulating games within a Single Interface across multiple games systems there is definitely enough within the current P-UAE core to support a nice Amiga playlist of the top 100 Amiga Games.