Android "Failed to Load Content" error Saturn games

Hi All,

I have Retroarch Plus on my Android tablet and regardless of the Saturn Core I load, Beetle or YabaSanchiro I can’t get any ROMs to run. I get the same error, “Failed to Load Content”. I even chose popular ROMs I’m not interested in just to make sure it’s not a compatibility issue.

When I try Googling the issue I see lots of PC Retroarch users getting the same error & their fix was to name the Saturn BIOS correctly & confirm it is in the correct folder. However I don’t see an equivalent remedy for Android Retroarch. I don’t even know what menu I’m supposed to go to for Android.

Please help.

We would need to see a log to even guess what’s going wrong, but if you don’t have a properly named BIOS in your ‘system’ directory (which you can locate by going to settings > directory), it’s indeed not going to work.

there are a few ways to get a log, but the easiest is to go to settings > log and set both logging verbosities to DEBUG and ‘log to file’ to ON. Do whatever it takes to reproduce the offending behavior and then close RetroArch (if needed). It will then create a log file in your ‘log’ directory, which you can open in a text editor. If you want us to take a look at it, copy/paste the log contents somewhere like and then post a link to it here (this is more convenient for people than having to download it and open it in our own text editors)

1 Like

Ok thanks, at work right now but I’ll try and do this tonight and post it.

1 Like

Thanks @hunterk got home and put the BIOS files in the folder you mentioned and now the ROMs all load up. I’ll let you know if I run into any issues.

1 Like