Android Nightly discussion thread


#341

It worked fine on my end a few days/a week ago. Just tried my sure-fire way by nuking the list of custom mupen options on the core .cfg file in “/sdcard/Android/data/com.retroarch/…” (worked when I set rice and kept crashing before an update fixed it),but it still crashes before booting. Why must this core always be so sensitive to changes,and so close to ParaLLEl whenever its built? :frowning:

Edit: Darm it! The rewind and shader enhancements are causing the crashes again! Turning both off made it boot again. The core version before I updated allowed rewind to be on and used.


#342

On the latest 1.3.6, the MAME core is rendering games at only 4/3 screen ratio. Forcing 16/9 in the video configs do nothing with using either the GL or Vulkan render paths. The ratio works fine for Genesis emulation cores. If this has been posted already, thanks Obama!!


#343

Sorry for the late response I´ve been busy with work, in fact I always delete all except the saves and do clean installs, on my new GPDXD was the first time installing and had the same problem at first I tought it was due to JXDS192 shi… performance then I used it on shield devices and the GPDXD with the CFW and overclocked governor that plays even saturn games fine, I even tried on a real nexus 5 and got the same results, what really intrigues me is the fact that in all of my reports like the previous MAME ones you always say it works fine on your device when I tried all sort of things even with custom roms and governors including using lollipop,kitkat, custom rom and the new stable final update of the shield portable rom maybe something wrong on my end? anyway you’re doing an excellent work I understand these are just beta releases so is expected to find bugs and problems after all that’s because this is a feedback thread guys

PS If you want to fast replicate the issue try “SUPER PC GENJIN 2” (super bonk 2) or try battling the eye thing boss on demon’s crest you`ll see the flicker on all snes cores except on catsfc


#344

Why has the Angrylion plugin never worked? Is cxd4 missing LLE mode when angrylion is in use? The cxd4 RSP uses HLE on its own when Glide64 is selected,I can tell by the half decent speeds. I am asking to help a Mupen64Plus AE developer who wants to try porting the plugin to see how it would run on standalone. The cxd4 RSP in HLE and LLE mode has already been successfully ported to Mupen64Plus AE and runs fine in both modes thanks to GLideN64.

I tried setting all of the RA Mupen core parameters to: Pure Interpreter,very high,angrylion,cxd4,1500,original,VBO=off,and 640x480 resolution. All of this,after all this time,and it still refuses to run even SM64,the easiest game to try for the best compatibility,it gets the same black screen,but at least no longer hangs RetroArch itself.


#345

There’s a high chance one reason why Angrylion and even ParaLLEl refuses to work properly on Shield TV is because of shader compilation errors. I know this is possibly what it is since a port of Angrylion on stand-alone Mupen64Plus AE booted with a black screen until the dev briefly fixed a shader compilation error that was found,now it (albeit slow) works perfectly fine.

The problem is that RetroArch outright refuses to boot games on either plugin,so there is something else wrong,I wish you luck in finding the cause of this issue.


#346

Having trouble installing the nightly build without a second storage. And still having a problem keeping the nightly WITH a secondary storage. Ok the playstore version works fine, just a little outdated.

First, the With secondary storage. Using an odroid, which has a FAT partition for the boot.ini configuration file. it’s only 126mb, so it’s almost nothing. If i install the nightly version, it’ll be gone after the next reboot, the icon will be on the homescreen, but clicking it will say the app isn’t installed. So it’ll install, but it won’t hang around, though the files will all be there, even the ones in the data/data

Which brings me to… I can unmount the FAT partition after the system has booted. Once i do, it no longer allows me to even install retroarch, it’ll just tell me the App is not installed. Straight up fails to install. If anyone knows a solution that doesn’t involve using the playstore version. Let me know.


#347

I had the same on my shield tablet with adoptable storage… really dunno why. Worked fine on other devices with adoptable storage too.


#348

[QUOTE=Myst3r90;20404]Hello

Again, congratulations to the developpers for Libretro/Retroarch

I’m having issues with the latest nighlies (including the last I downloaded yesterday, the 15th of march) The app crash after about 3 minutes of gaming. I would like to give you more info, but I don’t know where to find the log

My device is a TV ANdroid Box, with RK3188 core, and Kitkat 4.4.2

Myst3r90[/QUOTE]

Get A Dictionary!!! Developers


#349

What’s your thoughts on the Snes9x 1.54 update? It mentions a libretro core,but that is likely only for desktop platforms currently,hopefully it can be added to Android sooner or later for its nice improvements. I would say DON’T replace a version with it but instead make it an entirely new core slot like exactly Snes9x 1.54 (maybe Snes9x 2016 to fit the other year-named cores) because of the more accurate soundchip emulation that will likely break many SMW etc. hacks more-so than they already might do in certain points.

http://www.snes9x.com/phpbb3/viewtopic.php?f=8&t=23752


#350

Regular ol’ snes9x-libretro has been in step with mainline for a long time.


#351

Do you guys know why Retroarch stopped saving contents to the SD card? I can’t save states, only load them, in the nighties builds it stuck in 0%, the stable build just says it failed to save state. I never had problems like these before.

I was using adoptable storage for some time, and it was working, but before, in Android 4.3 and 5.1, I used the external storage, and RA never had problems. Last week, I decided adoptable storage has more disadvantages than it has advantages, so I converted the SD card as external storage again, as exFAT.

RA also has permissions to read/right from the SD.

Edit: It does save states in internal memory.


#352

Because Google changed runtime permissions again in Android 6. Writing to the sdcard is now “dangerous”. And needs to be granted at runtime now. No-one has bothered to implement the new permissions model since it’s java crap and we hate it.


#353

I was reading about it right now man. No big deal, I`ll use internal memory for it.


#354

I managed to use save states in the external SD now, in Android MM 6.0.1 using the folder mount technique. The app called Folder Mount wont work in MM for me since it asks for SuperSU, and AFAIK, MM from cyanogenmod has a built in root option, which for some reason Folder Mount doesnt support. Apps2SD is working fine here, all my save states are going directly to where I always saved, in the external SD card. Ill use it this way until RA implement the new permissions model as Radius mentioned. I also got all my roms unzipped, except for the arcade ones, since I dont like them to be stored elsewhere, I don`t see the point having them compressed if they need to be unzipped and then read before the game opens, I should have done this a long time before.


#355

I accidentally set a video filter, how do I unselect it? The only choice I have is to select a different one.

This menu is a complete usability nightmare but the emulator is great.


#356

press retropad start on the option to return to default. If you don’t have an external gamepad connected, you’ll need to go to settings > onscreen overlay and disable ‘hide overlay in menu’ or whatever it’s called so that it shows all the time. I personally like this better than using the regular touch menus anyway.


#357

Two doubts that I’ve been thinking about:

To update RA in Windows, I replace exe and some other files, leaving cores and configs intact, in Android, I install the apk and it updates sometimes, but for some reason, sometimes the only way to install a newer build is by removing the current one, which removes configs (although I noticed that the latest versions can read configs from the internal memory in “Retroarch” folder, not stored inside Android/Data directory), cores, etc. When it happens, is there a easier way to update, or it should just be installed by the APK? Is it my phone that sometimes doesn’t let me install a newer build?

In the nightly folder, we can see the latest cores, if I download them using the core updater inside Retroarch, the latest cores are downloaded, or the ones available are the stable version?


#358

Cores are always the latest nightly builds.

Yeah, just remove the old one and install the new package. I’m not sure what causes it but it happens on my Shield ATV sometimes, too.


#359

[QUOTE=hunterk;50692]Cores are always the latest nightly builds.

Yeah, just remove the old one and install the new package. I’m not sure what causes it but it happens on my Shield ATV sometimes, too.[/QUOTE]

Good to know man,thanks a lot.


#360

Hi, the last nightly crash in my android jelly bean 4.1 (weird because works fine in 4.4.2), I don’t have this issue with 1.36 stable.