Android Nightly discussion thread


#381

You can switch to the playstation-like menu by going to settings > driver and changing the menu driver from glui to xmb.

The Stella color issue is actually part of a larger issue that we’re still working out but should at least be back to its old behavior in more recent nightly builds (of RetroArch, not the core itself).


#382

Thanks hunterk, now the playstation menu is back!!

However, I’m trying to set the Explorer directory to start inside my ROMS folder located in /emulated/0/ROMS, but when I enter the ‘load content’ option, It doesn’t start in the path I defined (inside the ROMS directory in this case) and so I need to open all the way to the ROMS directory to select my roms everytime. This option was working in the previous version…

Thank you for your help and keep improving this superb platform :smiley:


#383

Oh I forgot to ask one thing… Is there a way of doing MAME core to read my .cfg and .ini game config files if I copy them from my computer to my Android device? If yes, where should I drop these files so Retroarch’s MAME core would recognize/read them?

I’m asking this because every time I enter an arcade game to play through the latest MAME 0.174 core, I have to access the internal MAME UI and set all the buttons, and this is kind of annoying :confused:


#384

Yeah, some of the MAME cores will create the necessary directory structure automatically while others will require making them manually, but I think it’s [savedir]/MAME/[whatever]


#385

Latest mame core cause RA crash

Tested in galaxy s6 miui port


#386

[QUOTE=brujo5;53619]Latest mame core cause RA crash

Tested in galaxy s6 miui port[/QUOTE]

Even if it is a useful and detailed information can you elaborate, post a logcat ? otherwise it works well for me.

http://imgur.com/1dBT1o1 http://imgur.com/XwbETyd


#387

Mame 2014 and all others cores work fine. Only hvae problem with mame 0.174


#388

last mame core is 0.181.


#389

Damn fixed after deleted all config files.

Work super fast in miui port. Thanks


#390

I can confirm strange color issue (blue) with thumbnails and possibly elsewhere; appears this is a known issue. I’m also receiving random crashes of retroarch when selecting “close” from the quickmenu – this behavior is happening on two different devices.

Aside from the above, the “scan folder” option didn’t work for folders containing zipped files (there is a work around) – known issue: https://github.com/libretro/RetroArch/issues/3807


#391

I can confirm the coloring issues, it also appears when using overlays; red appears blue.

I am using the 12-25 build


#392

Can you try updating to a more recent build? We’ve done some work to hopefully resolve the red/blue swap.


#393

Blue Color Bug is fixed. 04.01.16 build


#394

w00t! Thanks for testing, Seedlord.


#395

Tested the latest android .apk and confirmed that the blue color is fixed. However, my MAME core stopped working for good, no matter what I do. I’ve tried removing and reinstalling it from scratch, but Retroarch refuses to start my MAME games and crashes with the following message: “FAILED TO OPEN LIBRETO CORE”. How can I solve this issue? Please heeeeelp! :confused: I did several core updates taking different retroarch .apk versions but it just won’t open my MAME games anymore. The older MAME versions (2000 and 2003) are working, but I want the latest core, since these two are very outdated.

Just for the record, before updating my retroarch today, I was runnig the MAME 0.174 core without any problems. It was working just fine in my GPD XD device and it was quite fast. And besides MAME, I can run both Stella and Game&Watch cores without any problems. It’s just the latest MAME core that stopped working. And in my Motog Cellphone, I can update and run the latest MAME 0.181 core, so it could be something related to GPD devices only. Any clues or tips on how could I solve this issue is welcome! Thanks


#396

Hi there!

I updated my RetroArch installation from nightly build 2017-01-11 to 2017-01-24. My retroarch.cfg contains the options

video_shader = "/data/data/com.retroarch/shaders/shaders_glsl/xbr/xbr-lv2-accuracy-smart-blur.glslp" video_shader_enable = "true"

To disable shaders on N64 and PSX games my core specific configs for GLupeN64 GLES3 and PCSX-ReARMed contain

video_shader = "" video_shader_enable = "false"

Config overrides in general are working. Only shaders aren’t disabled automatically when starting an N64 or PSX game. On my previously installed build it worked.

Have a nice day!


#397

Try using the new ‘save core preset’ option to save a core preset for those cores using only ‘stock.glsl’.


#398

Thank you for your advice.

Unfortunately it seems like an enabled shader will not be overriden neither via core config nor via core shader preset if it was enabled on global space.

What currently works well is to move shader settings to core specific configs or presets and keep it off the retroarch.cfg. So I created config override files for each core that should use the mentioned shader preset.


#399

Onscreen Overlays (retropad) still don’t work for input on Shield TV for the useful parts it has.

Is anyone going to ever look into fixing this issue? It was said that the only thing needed is mouse support within RetroArch,and for example,the Shield TV Nougat OTA upgrade changed the UI to include mouse detection for highlighting options since the controller even supports mouse movement functions.

A neat bonus is that Opera for Android (a rather old version,no less) oddly supports right cliking in the omnibar via my K400 Plus keyboard.

Also,RetroArch works decently in a freeform window via the excellent “Taskbar” app,so that’s pretty cool as I can use a browser to check something or look up a guide when stuck without completely exiting out of it,too bad overlapping windows with full screen isn’t currently possible.


#400

I am not sure that for each core we need different BIOS files? Like for mame2003 mame2014 cores we need different bios files when play some of the games? Where to get all these bios files for my android device? @radius