Android Nightly discussion thread


#421

Somebody knows how to get sound on latest builds? no matter what I have mute sound on everything I use including nvidia shield and gpd q9

EDIT; NVM new sound driver needed to be changed on options thanks


#422

BIOS ROMsets and Parent ROMsets are two different things. MAME requires BIOS files for all types of sets (Merged, Split, and Non-Merged). Parents are only required for Split sets.

Unlike with most cores, MAME cores use BIOS ZIPs that are stored in the same folder as the MAME ROMsets.


#423

Hi, I know this isn’t the right place, but there does not seem to be any way for me to post a new topic in this forum.

I installed RetroArch on my Samsung Galaxy S7 Active Android phone. The interface is unusable. The text is far too large for the screen and hilariously the only way to interact with numeric settings is to increment them by tapping. The app freezing if I go to Help > Menu Controls has also been a source of grim amusement.

I used GameBoid on an older phone and it was great, but it has interface issues on the new phone due to a higher resolution than the app seems to have anticipated and due to the settings icon being inaccessible. I was directed here from the SourceForge page where I was checking for any newer releases. I just want to play GBA games on my phone.


#424

Ok, I recommend going to settings > onscreen display > hide overlay in menu OFF and then go to settings > driver > menu XMB.

That should make the menu easier to navigate using the touchscreen gamepad controls.


#425

Ok, I recommend going to settings > onscreen display > hide overlay in menu OFF and then go to settings > driver > menu XMB.

The first step placed a stretched button overlay on top of the interface. Dragging and tapping were disabled. I could scroll menus up and down with the d-pad, and I think I managed to exit the settings and go to the home menu by tapping “A”. I was not otherwise able to interact with the menu. I restarted the app and tried changing the menu driver to XMB and there was no apparent effect. I also tried the other option, rgui, but this had no effect either.


#426

The menu change won’t take effect until you restart the application.


#427

You got a screenshot.

I have a S7…works ok for me


#428

The menu change won’t take effect until you restart the application.

I did try restarting the application. The setting as shown in the config menu persisted but there was no apparent different in functionality.

You got a screenshot.

I have a S7…works ok for me

All of the text is like this, making it very difficult to navigate. Many UI elements in the settings menu are not possible to interact with except for incrementing the displayed number by 1 or 0.01.


#429

I am on RetroArch 1.6 on an Amazon FireStick (Android). What is the easiest way to upgrade to the latest Nightly version without losing all my stuff? (Cores, Content, Input and video settings, Icons, ect)


#430

if you can use adb from a PC, the easiest way is to download a nightly and then adb install -r.

If not, you can try our FDroid repo, which feeds up nightlies.


#431

Interesting. How would I go about doing either of these methods? lol


#432

for FDroid, you would install the FDroid app and then add this repo to the app’s sources: buildbot.libretro.com/fdroid/repo


#433

I’m trying to change the location of savestate_directory and savefile_directory in retroarch.cfg from

savefile_directory = “/data/data/com.retroarch/saves” savestate_directory = “/data/data/com.retroarch/states”

to

savefile_directory = “default” savestate_directory = “default”

So that .state and.srm files are saved in the same directory as roms. This works before I start RetroArch, but when I close and relaunch, the values are changed back to the original. I’ve even tried creating my own custom cfg file with the values I want (at the top of the file, for easy location) but, again, when I load this file in, the values are instantly overwritten with the original ones.

What’s doing this and how can I prevent it?


#434

I can’t repro this. I just tried on my phone and it always does “default” just fine.

Also it doesn’t default to savefile_directory = “/data/data/com.retroarch/saves” savestate_directory = “/data/data/com.retroarch/states”

It defaults to /sdcard/RetroArch/saves and /sdcard/RetroArch/states.

The only reason for it to do those changes is when it can’t write to the SDcard, and only on the first run…


#435

I’ve tested several of the nightly builds over last few days. They all have the same problem with menus. For example on the driver menu I can only change input driver. No matter what menu item I touch the input driver is always affected.

There are other menus broken the same way: only the first menu item works.


#436

Strange my S7 looks notbing like that, all text is fine (cant seem to add a screenshot to post on the phone). Never had an issue with the screen layout.

Yes the incremental settings are a little pita but not a major concern


#437

I’m having a different issue with my s7. Save states don’t work. It’ll say “saving state” in the corner but stays at 0%. Also, bsnes (Regular and mercury) crashes.


#438

I just have a quick question. are the cores in the armv8a release of Retroarch the exact same as in the armv7 release version? would there be any compatibility differences or is it just enhancement of the performance of the retroarch gui?


#439

You tell us :stuck_out_tongue: They are there for people to test


#440

I NEED HELP :frowning: I have Retroarch on ANDROID TV BOX I have roms that were working on my RETROPIE but they do not work on any of the mame versions ?? WHY ?? it hanges and needs a reboot… If I get one game working I cant use credit keys ?? HOW DO I CONFIGURE !!!