Any support still for shaders per .cfg file?

So I use Retroarch along with my frontend to launch games using different .cfg files depending on what I want as far as shaders and which monitor to play on but ever since newer versions of Retroarch have overhauled the system that shaders are saved with I’m confused on how to make this work like it used to, I don’t see any options in the xmb and directing Retroarch to a preset in the .cfg manually doesn’t seem to work like it used to so I’m confused. I hope there is still support for shaders on a per .cfg file basis otherwise for my niche uses I’ll be forced to reapply shaders every time I start Retroarch.

There’s now a command line option, –set-shader /path/to/shader.extp, that will load a shader at launch, so no need for embedding it in a cfg.

Great to know! Thank you

I can’t seem to make this work still. I’ve tried appending the command a couple different ways and still can’t get it to load with a shader.

Here is my command line for launching Saturn games I’m testing this with before anything

Retroarch.exe -c “config\retroarch - 4kTV no rewind_saturn.cfg”

I’ve tried changing my command line the following ways, I’m attempting to use a configuration of CRT Royale I saved in my root /shaders folder

  • Retroarch.exe -c “config\retroarch - 4kTV no rewind_saturn.cfg” –set-shader /shaders/royale.cgp

  • Retroarch.exe -c “config\retroarch - 4kTV no rewind_saturn.cfg” –set-shader D:/Retroarch/shaders/royale.cgp

  • Retroarch.exe -c “config\retroarch - 4kTV no rewind_saturn.cfg” –set-shader royale.cgp

I tried placing all the paths to the shaders in quotations, I also tried to change the character at the beginning of the “–set-shader” command you mentioned to a “-” instead of “–” this character but still nothing is working. Any idea what I’m messing up here?

Edit: Nevermind finally got it working, checked to -help command and saw the command needs started with “–”

1 Like