Anyone get Atari 5200 working under RetroArch?

did you read post above? anyways, atari800 3.1.0 does seem to work. if you want this to be able to auto-load the 5200 roms do what is stated above, meaning you have to manually load the games, choose two or one chip 5200 cartridge and then save the new cartridge. this will write headers to the rom so the emulator can detect it if its a two or one chip cart.

controller will works if retroarch support it. But I had no feedback from the author , so i keep the core for my own use until he accept the libretro port. i cant share it. at most i can share the libretro part and explain the 2 line hack it need in the upstream code ( only needed to escape endless loop and bypass libco usage). but that mean you have to build the core yourself.

For atari800 , i hack it to use crc detection on a52 rom, so now you should not have to add header or choose correct cart type, as long your rom match the crc .

If I was using this on a dedicated PC with a keyboard connected, that would be fine. The system I am using the emulators on is a dedicated HTPC, where 99% of it is controlled by a remote control (based on Windows Media Center). There is no keyboard for 99% of things used here.

It’s setup so I can use a remote control, Select ES, and I use my Xbox 360 controller, when I exit ES, it goes back to the HTPC (with a remote). So using a keyboard to play one of the 8 systems that are setup, kind of defeats the point here.

OK, I tried :grinning: I hope he gets back to you soon ! Like I said, if you NEED a beta tester to make sure it WORKS, let me know !

So, with your update, should it run 5200 games with out going into changing it ? I’ll try it tonight…Crossing fingers here !

EDIT: I looked over your code… I see these…

74 + { a5200,“qbert.bin”,8192,0x3fe4a401},
************** 75 + { a5200_ee_16,“qix.bin”,16384,0xaea6d2c2},
76 + { a5200,“questroo.bin”,16384,0xb5f3402b},
77 + { a5200,“rsbsebll.bin”,32768,0x44166592},
78 + { a5200,“rsbktbll.bin”,32768,0xdd217276},
79 + { a5200,“rsbktbll1.bin”,32768,0xc90196fa},
80 + { a5200_ee_16,“rsbktbll2.bin”,16384,0x0f996184},
81 + { a5200_ee_16,“rsftball.bin”,16384,0x4336c2cc},
82 + { a5200_ee_16,“rssoccer.bin”,16384,0xecbd1853},

… My QIX game is named…“QIX (1982) (Atari).a52” does this mean it will need to be named or it wont work ?

Of course I cant say it enough, thanks for your help here ! The 5200 needs more love than people give it !

@r-type I tried your updated file. No love here at all in my trials sad to say…

I started by trying my “QIX (1982) (Atari).a52” file. I got the error “You need an official Atari OS for this” (or something of the sort). So I did the F1 thing on the next try, selected the 5200.rom (the bios for the 5200).

At this point for the QIX game, I have 3 copies, One the original (QIX (1982) (Atari).a52) that has meta data, etc, the copy (QIN.BIN) and the bad rip (QIX (b2).bin)

I tried it again, blank screen, renamed the file as you listed above, (qix.bin) and tried again, BLACK screen again. Hit F1 again, selected 2 chip 5200 game and it played. It went into the menu, so I grabbed my controller that is setup in RetroArch (all my other systems work fine with it), hit START, nothing, hit every button on the controller…Nothing. Again, I could see the game available but, I could not play it because my controller didn’t work with it.

Pretty much the same results as above. Sorry to say. No other game would play right off the bat, I tried about 6 games, and all of them had a black screen till I changed some settings using the F1 key.

Thanks for trying…


your almost there. with regards to Black screen, i just had to press button-1(whichever it is in your gamepad for this core) and it should play. it will also help to go into quick menu > controller and choose Atari Joystick(not the default Retropad).

Since you are already seeing the game loaded, press F4 to start game.

Seeing the “You need an official Atari OS for this” (or something of the sort)" means you have not set your bios path yet. scroll a few posts above since i already posted how to set this up.

Is it possible that you could share this with me? I can try and build the core from source and test it while the author replies :slight_smile:

Btw, I don’t seem to have any problem with your a800 core, I build it directly from source, but the auto-detect cart thing is an awesome idea! now I just need to get a compatible romset :smiley:

This system is giving me too much trouble on RetroArch. MAME and MESS cores in the updater don’t work (they all crash), the only thing that makes it work is a modified (i think) MESS core i found somewhere else a year ago. And that only works through RocketLauncher and only when using an older RetroArch module.

It’s so specific that i don’t even know how i managed to make it work. Also, “work” is a strong word, MESS is very bad at emulating the 5200, more than half of the games don’t even boot with it.

The atari800 core didn’t work for me either but even if it did, i don’t know if it’s possible for it to launch games without having to fiddle with extra menus and the keyboard.

Basically, there is nothing in RetroArch that is good for the 5200, especially if you want a couch living room setup with no keyboards around to fiddle with. So the only thing that left for my setup is KAT5200, it works with all games perfectly but it’s not RetroArch (i can’t use shaders for instance). I wish there was a KAT5200 core somewhere, i have no idea if the emulator is open source or not.

I don’t understand why it does not works for you.

I’ve just tested with an win7 64 bit , with the last core I upload here
and all work fine with QIX.

i use Good5200 v2.01, and for QIX the a52 rom the 16kb one . I just load content from retroarch and it load fine. no menu asking me the cart type !

After just press F4 to start game ( your problem is that you don’t have keyboard to start game as for now A5200_START key is bind to F4)

Ok this latest version does work for me.

However, some games give me a test screen of some sort instead of the actual game.

I need to dig through this a bit more.

which “some games?” if these are Atari 8bit games, there are other extensions (atx,xex,bas) that are not added yet so this will fail when loaded.

if its 5200 games, then rom not properly recognized, have to extract these games and try manually loading them as once chip or two chip 5200 cartridges, save it(if you want to) if you find the right way to load this rom.

One of them is Choplifter. It’s a 5200 rom (works in MESS or KAT5200). It’s already extracted and it’s a .a52 file. Can this file be extracted even further?

I cant look at today. Im afk. I will look at next days

looks like the hash matching from update is not picking up properly… rom still detected as type=0;

rtype, cart->size is being reported as KB so case condition does not match hench not able to assign proper type

See the problem is, I would only get “This program needs a TRUE Atari OS” meaning the BIOS is not located. After dropping in the bios (going into the menu and setting(, running via command line to confirm, I still ended up with a BLACK screen.

I am on my 4th rom from different locations and the Good5200 is something I have tried.

I will try again later today and see if F4 starts the game…

Cant answer your question but, I’ll try again when I get some time later today.

good catch ! thanks i uploaded/commit a fix. copflit works fine now.

Did you upload a new version to the same link above ?

@GemaH - Looks like @r-type is busy. so here is a download from latest commit. this should fix auto-loading of 5200 roms(this is for Windows x64)

Take note: that you still need to manually set your bios directory and make sure they are loaded in the cores System ROM Settings.

If you are having problems getting F1 to get to menu or core menu is not showing at all, just run rom/bios using Load Content(i think any file would do) this would cause failure to load the file but the core is now loaded and you can configure it with F1 key.

Then save settings by choosing “Save configuration file” from Emulator Settings menu-> this should be done as the core(at the moment) has its own config file and not yet saved into retroarch(so just closing core like others will not save anything)

Thanks, this version seems to load all games i tried so far :slight_smile:

Now there are only two issues left to solve. The first is that you need to hit F4 to start, is there any other way to do this with the gamepad without having to resort to things like xpadder? This wouldn’t be a problem if xpadder would load the config for the atari800 core alone but it doesn’t, it saves the preset for RatroArch in general (so your F4 key shortcut will function in all cores which is undesirable).

The second issue is that it seems like the second button isn’t emulated? Try playing Moon Patrol, the game uses two buttons, one to fire and one to jump. However, i can’t find the jump button anywhere. And there is nothing in the options. This is the same problem that exists in MESS.

If we could find a way through these two issues, then this core should finally fill the gap of the Atari5200 in RetroArch 100%.

Edit: Here’s a similar discussion about the two buttons in atari800

but it’s retropie related, i don’t know how these can be applied here.

the core is WIP so a lot of things will still get changed like key mappings etc. as of the moment keep sending in reports as this would encourage development of the core.