Anyone get Atari 5200 working under RetroArch?

I set DEFAULT_CFG_NAME to /mnt/sdcard/ for android. you should be able to save your conf now , or edit after.

http://dl.free.fr/emdutAQzd

Just wondering, Did you ever try this ? I got compatablity to work pretty well for the most part but, I was wondering if there was a better advantage to getting a desgined as a 5200 emulator.

Just wondering, as you did great with the Atari 800 emulator…

For now I just fork and made an rough /basic port of jum52 no time to work too much on it for now.

Ok, Thanks for the update and thanks for your help here !

Hi, thank you for this marvelous core better than mess. but Can you show me which are the key for the keypad 1-9 in order to use the overlay picture and acess to some useful options? thanks regards

ever heard anything back @r-type ?

Any chance of getting a (latest version) compiled Atari800 or Jump52 core for Android? The one posted here fails to load on my AndroidTV box, let alone run… (on MM). I’m clueless about compiling it myself… Thanks

yes and it would be nice if we could have the new Atari800 Core Improvements of the recent news for Android. thanks regards

I can’t start games with gamepad START button, only with a keyboard F4… I have edited .atari800.cfg however, it doesn’t work. I tested it with Choplifter.

What I did was to add following lines to .atari800.cfg, but then no change:

SDL_JOY_0_SELECT=8 <-- button ID
SDL_JOY_0_START=9 <-- button ID
SDL_JOY_0_TRIGGER1=1 <-- button ID
SDL_JOY_0_TRIGGER2=2 <-- button ID
SDL_JOY_0_ASTERISK=0 <-- button ID
SDL_JOY_0_HASH=3 <-- button ID
SDL_JOY_0_SECOND_AXIS=2 <-- axis ID
SDL_JOY_0_INDEX=0 <-- index of P1 joystick
SDL_JOY_1_INDEX=1 <-- index of P2 joystick

I was reading here:

Then here:

And here:

No success so far. Can you help me to fix this?

I’m also having trouble getting atari 5200 games working. I have loaded the atari 800 core and placed the 5200.rom inside the /system folder. I also set atari800_system = “5200” in the core options config. I am still getting the following message in the emulator when I try to run this command: D:\RetroArch\retroarch.exe “D:\ARCADE\Atari\Atari 5200\ROMS\Astro Chase (USA).zip” -L D:\RetroArch\cores\atari800_libretro.dll

“Sorry this program needs a real Atari/OS visit the Web pages to find out more”

Any assistance is much appreciated!

You have to copy the bios files 5200.ROM ATARIBAS.ROM ATARIOSA.ROM… take a look to atari800.cfg samples online.

For those who have successfully gotten Atari 5200 games to run with the libretro-atari800 core - have you found the colors to be off? I’ve been using the standalone atari800 emulator on a Raspberry Pi3/Retropie setup and it works fine. I installed the libretro port this week and noticed the colors are way brighter to the point of looking completely washed out. Something weird with my setup or is this others experience on this core as well?

it does look a bit off:

Glad to hear I am not the only one. Today I tried it on my Windows 10 x64 PC and on that platform the colors look right. I am running RetroArch 1.6.7 on Windows, while the Pi is upgraded to 1.6.9. So I’ve got some more comparing to do to see if I can figure out what is up.

UPDATE - After doing some more troubleshooting, it looks like the issue had to do with my original (standalone) Atari800 configuration file. I guess the RetroPie install of the Libretro core also links to this config file to pull settings in, and I’m assuming some video brightness setting was turned way up on my config file as when I deleted my config and relaunched the core the video looks correct now.

First screenshot is the loading screen on Windows. Second screen is the same ROM on the Pi3.

I’ve tried this. I loaded roms and modified the configs as per this link:

But I still get the same message as before: “Sorry this program needs a real Atari/OS visit the Web pages to find out more”

Anyone else have any tips?

Anyone fixed the F4 - Start button issue?

I have determined that this is not an emulator issue or a configuration issue, as I can load and play 5200 roms by launching them through the Retroarch UI. But when I attempt to run them via the command line, that is when I see the “real Atari/OS” message. Here are the command line args that I’m currently using:

D:\RetroArch\retroarch.exe “D:\ARCADE\Atari\Atari 5200\ROMS\Asteroids (USA) (Proto).zip” -L D:\Retroarch\cores\atari800_libretro.dll

Does anyone know if it’s possible to print the commands that Retroarch uses to launch a game? When it launches a cmd window, the command is not displayed, only the program’s output.

I have all ROMs correct in .atari800.cfg, but when I load a game after the cartridge selection screen it always goes to MEMO PAD screen. Any ideas what I am doing wrong?

Okay so I had to change to

MACHINE_TYPE=Atari 5200

and that has me to an Atari logo screen, but I always get “”!!! this Atari computer has crashed !!!"

Okay, so my problem here was the ROM path entries in .atari800.cfg. I had them as absolute Windows’ paths (e.g. “ROM_OS_A_PAL=C:\RetroArch\system\ATARIOSA.ROM” ) simplifying them to relative paths with Linux slashes thus, ROM_OS_A_PAL=system/ATARIOSA.ROM, made it progress from the memo pad and into the games.