Applying shaders crashes RetroArch 1.7.6 on macOS


#1

Hi!

When I apply GLSL shaders in RetroArch 1.7.6 Stable using OpenGL on macOS the app crashes. In 1.7.5 it worked flawlessly. I couldn’t try Metal + Slang shaders yet due to the currently broken Metal build. But I also tested the Android version using OpenGL + GLSL shaders which worked. So it seems to be an only Mac related issue.

The log only says:

[INFO] [Shader driver]: Using GLSL shader backend.
[INFO] [GLSL]: Checking GLSL shader support ...
Segmentation fault: 11

Kind regards


#2

They’re in the process of moving everything to Metal as Apple is deprecating OpenGL, you should stick to 1.7.5 as horrible bugs are bound to appear in the process…

But yeah, it doesn’t seem to work atm…


#3

Same. Crashes in a way that it’s impossible to force quit the app, so a reboot is needed.

Thought I was going crazy.

Have reported it: https://github.com/libretro/RetroArch/issues/8207


#4

1.7.5 Metal works fine, so let’s try to not spread FUD about the Metal build


#5

1.7.5 is fine yeah ! Stay on 1.7.5 for now if you want stability…