Archive of RetroArch for iOS 5.1.1?

Does Anybody have an archive of the latest version of RetroArch that runs on iOS 5.1.1? I found a post from 5 years ago that had a link to a post, but the link now leads to an error 500 page.

I’ve just found out how to Sideload an application and found out (somehow) that my iPad supports iOS 10 (maybe more?) apps, as long as it’s a 32-bit app, so I’m now wondering if anybody now has at least a 32-Bit .IPA file for RetroArch.

@GiraffeMan3125 You could use my IPAs to test, but they’re compiled for iOS 6 minimum… I can try to compile one for iOS 5 if it doesn’t work for you!


EDIT: BTW, you will have to download iOS 6 version, unzip the IPA first, open the info.plist file, edit the line:

	<key>MinimumOSVersion</key>
	<string>6.0</string>

to:

	<key>MinimumOSVersion</key>
	<string>5.0</string>

Then zip again the Payload folder, and rename it to .ipa instead of .zip

If this works, I’ll make the change in the next version I put on my website and Cydia repo!

I’ll try it out later.

1 Like

Retroarch crashes when it opens. (plz ignore the terrible framing and stuff, I just used the app for the first time.) here’s a video of it. https://drive.google.com/file/d/1ukt0IuPM-Hrr_3IFZKNV3WrwLFA0R9QJ/view?usp=sharing

@GiraffeMan3125 Ok, so let me try to compile a version for iOS 5 real quick…


EDIT: Can you try this one?: https://www.mediafire.com/file/va2zjhjc4j8sn17/(iOS+5)+RetroArch+1.9.0.ipa/file

The .ipa you linked worked!

Emulating any games (I’ve tested NES, SNES, GBC, N64, and DS) will crash the app.

Ok, I will try to see what I can do, but it seems to be related to the cores themselves…


@GiraffeMan3125 What is the buildbot url that you got in Network > Update Settings?

(You may need to show advanced settings in Interface settings for this option to appear)

Is it http://johan.margueritte.free.fr/buildbot/ios/?

The BuildBot Cores URL is set to that (HTTP://johan.margueritte.free.fr/buildbot/ios) and BuildBot Assets URL is set to http://buildbot.libretro.com/assets

@GiraffeMan3125 Yeah, so my cores don’t seem to be compatible, which is strange since I compile them with iOS 5 support minimum…

If it’s a permissions problem, you could try to change the cores folder’s permissions or core permissions themselves to mobile:mobile or root:mobile or root:wheel…

If it’s not the permissions, you may try the official buildbot: http://buildbot.libretro.com/nightly/apple/ios/latest/

I have no idea how to change the permissions, and for some reason, when I close the app, all my settings get reset. (including the Cores URL)

@GiraffeMan3125 Ok, you could try the official buildbot anyway…

For settings, you now need to save them manually in the Configuration File option, in the main menu…

I switched over to the official buildbot (and saved my settings), downloaded a new core, but that new core still crashes.

Ok, I wish I still had an iOS 5 device to figure it out, but I think I’ll just have to remove the iOS 5 RetroArch I put on my website…


@GiraffeMan3125 I just thought about this, but you may very well HAVE to jailbreak for RetroArch to work, I just put an iOS 5 RetroArch version on the Cydia repo for you to try, if you are willing to…

Here is all you need:


Then you could delete the ipa version and install my iOS 5 version directly from Cydia after adding my Cydia repo ([iOS/tvOS] — RetroArch 1.9.0 and other emulators (Download/Cydia repo))…

I was already jailbroken when I tried this but I’ll try your repo.

It still crashes, and now when I switch the Cores URL, it says no Cores were found.

@GiraffeMan3125 You can stay with my buildbot which is more complete, can you try a simple core like 2048?

1 Like

Hi! I have the same problem that GiraffeMan. I tried with 2048 core but it doesn’t work for me. The app crashed!

I’m having the same exact issue.