Atari cores, game sounds are late to start, but in sync once started

Hello All,

I’m having strange sound issue that seems to only be happening to the following Atari cores: 2600 (Stella), 800XL (Atari800), and 7800 (Pro System). I have been scouring the forums for weeks without any useful info. I have tried any and all settings regarding sound and video sync without any favorable results.

Below are a few details regarding the issue:

  • If I have Retroarch screen notes turned on at game launch (eg) core re-map, controller info etc. I can see that the sound on some of the games will only start after the notes being displayed are complete and no longer on screen.

  • if sound doesn’t start at game launch, or after several seconds into the game, it will usually start once a certain trigger is executed, for example flying over a fuel-up in River Raid (Atari 2600) for instance, but shooting a ship beforehand won’t trigger the game sound to start.

Another example would be getting an artifact, flair, oxygen etc. on Spelunker (Atari 800XL), but jumping or moving the elevator will not trigger game sound to start.

One more example is Choplifter (Atari 7800) no sound until rescuing a person, but sometimes sound will start itself several seconds into the game…

  • As you can see, the problem is very sporadic and different on each title, and even when starting the same game right after exiting it will have different results, and some titles do not exhibit the issue at all, some have the issue some times, but not others…

  • The issue happens when games are launched in: launcbox, BigBox, and directly through Retroarch.

  • The issue also happens when in full screen and while windowed.

  • The issue doesn’t seem to be affecting any of my other 20 platforms using a mix of RA cores and standalone emulators.

  • I’ve tried several HDMI cables and ports on the TV without change.

System is an Atari VCS 800, with 32GB ram, and a fresh windows 10 install on a 2TB internal M.2 ssd. All drivers are up to date, and everything else is working flawlessly. These Atari core sound issues are driving me mad, hopefully someone has a few suggestions!

Thanks all!