Bad flickering in Fullscreen everywhere

Hi there. I am using retroarch since 1.2.2 and am very happy withbit. Great work! Since 1.3.4 in Windows 10 however everything is flickering when switching on Fullscreen. In rgui and ingame. Switching to d3d crashes ra immediately.

Hope someone knows what to do.

Greetings, Gem

Do you have “black frame insertion” enabled in the video settings?

Hi Lex. No, bfi is off. Default Settings everywhere.

Interesting. I’m having difficulty understanding the meaning of your use of “flickering”. Can you describe it in more detail? Is it actually tearing? Is it like any of the tests here? Try clicking the “Demo” dropdown and looking at a bunch of those demos, then link one if it’s like that. Try some of the other tests and demos in the dropdown at the top if none of the ones on the page I linked are similar.

Sorry. Rgui was wrong. I use xmb.

With flickering i mean it looks like every 10th Frame or so is Black. Picture,black,picture,black… and so on

I did some Tests and it looks like black Frame Insertion 15fps+3 Black frames

This sounds like some sort of video driver or hardware issue, as it’s the first instance I’ve heard of it and it does not happen to me. Can you try updating the driver for your video adapter? For Nvidia, you can get the latest version from . Just remember to select your video adapter series (600 if you have a 670, for example). For Intel and AMD, I’m not sure as I haven’t looked it up. Google will help you there.

If it still flickers like that with the latest video driver, it would be interesting to see your log. Put “retroarch.exe -v --menu > output.log 2>&1” in a batch (.bat) file and run it to generate an output.log file, then pastebin it here.

Hi Lex, I updated my driver - no improvement :frowning: but thanks for the idea. here is the log file

Any idea on this or do you need more information?

I’m about 90% sure it’s a hardware issue. Make sure your video card is being supplied enough power and if it is, it could be a “bad card” that needs to be RMAed.

Then again, if it doesn’t happen with an old version of RA, I really have no idea. That is beyond me.

Thanks for your reply. I am pretty sure it is not a Hardware issue. No Problems with other software or older retroarch. It’s a gforce gtx 750 ti. Ill try again when the next Version is out. We’ll see.

PS: I have news. I am playing on a Full HD TV and my graphics card was set to 1280x720. Now I tried 1920x1080 and the error is gone. But since games are more fluid in 1280x720 I’d like to keep this screen resolution. However, I thought this information might be helpful.


Hi, I Have the same problem on my TV screen… cause I play in 3840x2160 :wink: I have a GTX 960 on Win 10… I don’t want to put my screen on 1920x1080 'cauz it’s a 4K screen… Someone have an idea please ?

Something something 4K can only do 30Hz via HDMI or something.

I’m having similar flickering issues in Windows 10, the Retroarch overlay seems to flicker transparent frames showing the windows/desktop underneath.

I just spent days looking at various options for fixing a screen flicker on my RP4 running rarch with Lakka. BFI off and boom. Sorted. You’re a life saver. :slight_smile: Thanks Lex.

1 Like

Enabling Video in seperate Thread did the trick for me. Also yes Black Frame Insertion off.