Beetle PSX HW Gran Turismo 2 Sped Up

So I came back from having stopped playing a year ago and now the game is sped up, I tried other cores and other games with the same core and no such problems occur. I also checked to see if there was a fast forwarding option enabled and even reset my RetroArch configurations but to no success. I’m really at a loss here and any kind of help would be appreciated.

Do you have functioning audio? If not, try changing your audio driver and/or make sure you have directx 9.0c installed (note: this is not included in the latest directx installer) if you want to use the default xaudio2 driver.

Yep, all functioning and synced with the in-game fast-forwarded video.

Hmm, in that case, make sure no external programs are messing with your sync in any way (often GPU driver control panels). Also, make sure audio sync is enabled in settings > audio, and if nothing else works, you can set the maximum runspeed to 1.0 in settings > frame throttle, though this will break fast-forward.