Beetle PSX HW/non-HW: both give "failed to load content" errors.

Both of these cores give the same error. I am trying to play Vagrant Story, and the same ROM file works perfectly in PCSX ReArmed and less so in Swanstation (it loads, but has a frameskip bug), but I want to use Beetle because I hear it’s best for resolution bumps. Swanstation has resolution scaling but it always seems to have a frameskip bug I can’t pinpoint.

Anyway, I can’t seem to figure out why Beetle won’t load this content that other emulators load no problem. The cue and bin files match, and the text within the cue file matches the filenames. The bios seems to be good, I’ve tried both the US and PAL versions of the game but the same error occurs, and my RA has the correct BIOS for these (other emulators like PCSX use these same BIOS flawlessly). I’m at a wall about what to do.

beetle-psx is very picky about the BIOS. If you’re trying to run a USA ROM, make sure you have scph5501.bin and that it’s named exactly like that, case-sensitive (including file extension), no hyphens, no space.

Hey thanks for the response. I’m looking now and my bios is named exactly that. I’ll post a picture below of all the PS1 bios that I have. The ROM is US, but I’ve also tried different sources of the same ROM and I’ve also tried the PAL version too, which uses one of the other BIOS which is also named properly. None of the ROMs worked with Beetle but they loaded in PCSX and Swanstation without issue.

Vagrant Story works fine for me even if I “skip bios”. Might be worth noting that all my images are converted to CHD? The hashes were verified from what Redump has listed when I ripped them from my disk to .bin/.cue :slight_smile:

edit: forgot to mention I am also using HW version.

How do I skip bios? Might be worth a shot. I’m also going to try converting them to CHD.

I’m not quite sure what’s going on with my setup. The ROM is good because it works on other emus, the bins and cues match, the text in the cues match, the bios is good… I’ve tried using both HW and non HW and it’s the same thing, “failed to load content” immediately after a black screen and then right back to retroarch menus.

Just tried it after converting to CHD. Same issue, failed to load content while other emulators load it just fine.

You may try to provide some logs.

Thank you.


Hey gouchi, thanks for replying. Here is a link to my logs. There are two sections I’m seeing that may have to do with the issue. First is right after the content load on line 81, line 82 says there’s no TOC file detected (there is a TOC file in that same folder already), then 83 it says no tracks found. Am I wrong in assuming the “track” is the cue file that initiates the bin read? Then line 85 says the first and last track numbers are bad. It says track 99 and 98, but within cue files I have always seen TRACK 01.

Then at the very bottom on line 120/121, it says there are not enough samples for refresh rate estimation. I was thinking that could also be a culprit, but I’m not quite sure what it means. The refresh rate is set to 60hz within Retroarch.

This was taken using CHD files, but these same CHDs load in PCSX and the same errors were present in Beetle when I had the separate bin/cue files.


Thank you for the log.

You should avoid to use toc file as it seems to cause issue, I don’t know if it has been fixed since.

How do I avoid using it? Beetle auto generates that file every time I try to load the content.

When I only have a CHD or BIN+CUE in the folder, a TOC is always made automatically when I try to load content. It seems only Beetle generates these files, no other emulator does. Just tested this again, I deleted the TOC file from the directory, went to load the content, and got the same “failed to load content” error. I went to try and load the content again, and the TOC file was back.

According to your log, the RetroArch you are using is a homebrew from gamr13 for XBox.
I don’t know if this causes your problems, but have you tried the official builds for XBox on ?