Bizzare, system crippling problem caused by RetroArch

Sometimes, after playing in full screen, upon trying to exit the game, RetroArch will stop responding, and I am forced to end the task. After this occurs, RetroArch will immediately stop responding when trying to launch it again. Strangely enough, GZDoom will also stop responding upon launch after this occurs with RetroArch (I only mention this because it may help pinpoint the cause of the problem). This seems to put my system in some sort of error state, when I try to restart or shut down my PC, it will hang indefinitely on the restarting/shutting down screen, and I am forced to hard power down. I have a Windows error log, and two logs I generated in the command prompt. I would really like to resolve this issue, and any help that I can find here would be greatly appreciated. Thank you.

System information:

OS: Windows 10 Home 10.0.11763 CPU: Intel Core i5-9600k GPU: NVIDIA GeForce GTX 1660 Ti RAM: 16GB


Can you try a different video driver, such as glcore?

I could try that driver, but this issue has occurred on both “gl” snd “vulkan”. I will try “glcore” when I get home this evening. Thank you.

Ok, no worries. If you’ve already tried some other drives, it will probably happen with glcore, as well.

While you’re at it, could you see about getting a backtrace using the retroarch_debug.exe and gdb?

Okay, so I dragged the “retroarch_debug.exe” into “gdb.exe”, then I typed run. It successfully opened the program, which is something I was unable to do by just clicking on “retroarch_debug.exe”. Normally I would have had to reinstall RetroArch to run it again after experiencing the issue described in my original post.

Here is the text displayed in GDB:

This binary was built by Equation Solution <>...
Reading symbols from E:\retroarch\retroarch_debug.exe...done.
(gdb) run
Starting program: E:\retroarch\retroarch_debug.exe
[New Thread 1840.0x32ac]
[New Thread 1840.0x29f0]
[New Thread 1840.0x2c28]
[New Thread 1840.0x2404]
[New Thread 1840.0x120c]
[New Thread 1840.0x25e0]
[New Thread 1840.0x3d4]
[Thread 1840.0x120c exited with code 0]
[Thread 1840.0x3d4 exited with code 0]
[Thread 1840.0x25e0 exited with code 0]
[New Thread 1840.0x2e44]
[New Thread 1840.0xf20]
[New Thread 1840.0x2f5c]
[New Thread 1840.0xe08]
[New Thread 1840.0x1330]
[New Thread 1840.0x1ea4]
[New Thread 1840.0x1c94]
[New Thread 1840.0x33a8]
[Thread 1840.0x29f0 exited with code 0]
[Thread 1840.0x1330 exited with code 0]
[Thread 1840.0x33a8 exited with code 0]
[New Thread 1840.0x19dc]

So did it crash while running in gdb? if it does, it won’t close out, it’ll just freeze, at which point you need to type:


into the gdb prompt. That should hopefully give us more information about what’s going on.

I closed it, came back just now, and tried to launch it the same way through gbd. It freezes immediately upon launching it through gbd, and the gbd window is not accepting input. It is not frozen, but I cannot type in it. What I can do, is restart my computer (which I know will require a hard power down), launch “retroarch_debug.exe” though gbd, and use it till it crashes, then try what you said. Another thing I noticed that I should mention, when retroarch stops responding, the volume mixer window also stops responding. It happens every time (If I happen to have the volume mixer window open).

UPDATE: I attempted to shut down my PC, and as expected, it got stuck on the shutting down screen. I decided to let it go for a bit longer this time, and when I returned, my computer had blue screened. the stop code was DRIVER_POWER_STATE_FAILURE. The blue screen itself seemed to had frozen too, because it was stuck on 0%.

Hmm, that’s a GPU/driver error. Have you tried reinstalling your nvidia driver with the latest version?

After seeing that stop code, I changed some power settings, and it may have fixed the issue. I can say that RetroArch was the only application on my PC that I observed causing the issue. Either way, I am continuing to run retroarch_debug.exe through GBD, I will keep doing it for the next few weeks or so just to make sure. Thank you very much for the help.

1 Like