"Black Frame Insertion" audio problem


#1

I have a Trinitron CRT monitor and i’m running some of my games at 320x240 @120Hz so I can get scanlines. Unfortunately, I have to play with black frame insertion on otherwise the FPS will feel choppy with it off. Only problem with turning on “Black Frame Insertion” is it causes the audio to sound distorted and crackle. Some games are more severe than others. My question is why does “Black Frame Insertion” affect the audio, and can it be fixed? I’m running the latest Retropie and Retroarch on my Raspberry Pi 3B+.


#2

It shouldn’t have any effect on performance at all… So setting vsync swap interval to 2 makes it choppy? I guess you could try setting max runspeed to 1.0 and/or use the “flicker” shader, which basically does the same thing as BFI.


#3

Yes vsync swap interval = 2 does make the sound distorted/choppy just like with “Black Frame Insertion” enabled. . I tried the flicker shader and it doesn’t do anything like “Black Frame Insertion” does. The shader is overblown with high gamma and contrast and it doesn’t make the game feel smooth like “Black Frame Insertion” does. I really wish there is a way to fix the audio when using “Black Frame Insertion”


#4

This is literally the entire shader:

float check = mod(float(FrameCount), 2.0);
FragColor = texture(Source, vTexCoord) * check;

All it does is alternate each frame between showing the normal screen and full black. There’s nothing that touches gamma or contrast, though your display may be responding oddly to it or something. /shrug


#5

I believe it could be the shader i’m using provided here https://github.com/libretro/common-shaders/blob/master/misc/flicker.cg. The shader wasn’t present on my Retropie so I had to download it. Is there anyway you can provide me with the correct shader please?


#6

You can try this one instead:


#8

I tried that shader and it doesn’t function properly. I can see flickering but it’s not the black frame insertion kind. The image is overblown with gamma/contrast just like the first shader I tried. The shader has done nothing to make my games smooth. Scrolling Horizontally/Vertically still looks choppy. I tested with 240p test suite using the scroll test…


#9

Hello, I followed this guide here https://youtu.be/Y9E3KB0bmLY?t=380. For some reason, I stopped having audio distortion once I set the HDMI timings to 1920x240. I applied his settings of V-sync interval 2 and yet I’m getting what looks to be trails/ghosting. Using the 240p suite green hill zone scroll test the fluidity still isn’t like “Black Frame Insertion” but on the video, it shows that it is smooth. Is there another particular setting that I need to turn on to get V-sync interval = 2 to be fluid just like “black frame insertion”?