Bugs cores PUAE (Amiga) + GCE (Vectrex) + Vice x64 (C64)

Hello everyone :slight_smile:

I’m very disappointed & surprised that there are always more bugs in the versions of RetroArch for Android…

  1. PUAE (Amiga) & Vice x64 (C64): when I press Select to display the virtual keyboard then it is impossible to get out of it by pressing again on Select or Start ?! How to proceed ?!

  2. GCE (Vectrex): the games start upside down, it’s unplayable ?! How to proceed ?!

Thanks greetings :slight_smile:

I can’t reproduce that keyboard thing in PUAE/VICE on Android. Select makes it come and go like it should.

I tried these cores with several different phones & several versions of RetroArch but the bug is still present…

I do not know what to do ?!

The flipped vecx image in Android is known. I put in a PR to fix it, thanks to phcoder’s work to figure out the problem, but in the meantime until it’s merged, you can work around it by turning off hardware rendering in the core options.

There is no option you mention? What is her name ?

@hunterk OK thank you for the information about the Vectrex & for the virtual keyboard ?!

Does the keyboard issue happen with overlay only, and not physical controller? And if so, is the overlay overlapping with the virtual keyboard (which is also touch controlled)? I tried it in portrait mode, which does not overlap with the emulated screen.

That is the only thing I can think of, as in the touch is going to the virtual keyboard instead of the overlay button, which obviously should not happen, and which should be rather trivial to sort out (in the frontend, not the core).

@sonninnos hello thank you for your help :slight_smile:

Yes I use the virtual keyboard only with the overlay, this one works, it’s just that I can’t get out of it…

Do you have a solution ? Greetings !

I tried with my phone both in portrait and landscape, and the overlay does not overlap with the screen, meaning that it just works, so no dice then…

@sonninnos Hello !

What phone did you try on ? What version of RetroArh are you using ? I tried with:

  • Huawei P30 Lite
  • Samsung S20 FE
  • Xiaomi Note 10 Pro

On all these phones I have the same problem why It is not possible ?!

Motorola G50, and the latest RA+ and core version from the store.

@sonninnos OK & what overlay did you use ?

The default one obviously.

@sonninnos I found the solution :slight_smile:

I used an overlay for SNES & the virtual keyboard is no longer a problem… I don’t understand why the one for the PSX is a problem… it must be a bug ?!

Whot, I thought it was about the controller overlay, not cosmetic overlays… which makes even less sense to me.

@sonninnos yes yes it is indeed the overprint of the controller… why are you talking about something else ?!

Derp, I did not realize there are so many different controller overlays, so I assumed snes/psx meant overlay borders instead.

But indeed now I managed to reproduce it with both snes and psx overlays in landscape mode. It does precisely what I predicted, as in the buttons will be over the emulated screen, resulting in the press going to the underlying virtual keyboard key and not the overlay controller button.

Also noticed when in portrait mode that the controller button press also simultaneously presses mouse buttons even when the press is outside of the emulated screen. That can be “fixed” by disabling the mouse via the core option, but that is not a proper solution…

@sonninnos hello !

I tried disabling the mouse, it didn’t change anything… I understand the problem better now. Who should I report this bug to ?

& regarding the bug for the core GCE what solution do you have ?

Greetings !

The mouse issue is a completely different issue, so of course it won’t help with the toggling.

@sonninnos & for the Vectrex ?!

I don’t know anything about that, my focus is on Commodore and RetroArch.

1 Like