C64 autoload disk game question

I use G64 floppies and most have no problems. They load using the autostart option:

  • LOAD"*",8,1
  • RUN

However, there are some games that require a slightly different loading method. For example, the Ultima series:

  • LOAD"*",8
  • RUN

Another example of B.A.T.: LOAD"LOAD",8,1 RUN

Is it possible to change the autoload from:

  • LOAD"*",8,1
  • RUN

for example on:

  • LOAD"*",8
  • RUN


Very possible via the vicerc method since that is a built-in VICE feature, either globally or per game.

Create a file called vicerc for global or <game>.vicerc in saves for example when using x64sc core:


Other examples and header names for all different cores are found in system/vice/ named as vicerc-dump-<core>.

For autostarting a specifc program instead of first you can use a .m3u file with contents:


.cmd can do the same thing but requires quotes around the whole row.



@sonninnos I made a file (vicerc with the name of the game) in the saves folder and it works great for the Ultima series. However, I don’t understand how to run B.A.T. by autostart i tried to change it in the m3u file but it mistypes something and it crashes RA. If you can run B.A.T. via autostart:

  • LOAD"LOAD",8,1
  • RUN

Could you please tell me what and where exactly to enter, because I’m a bit lost :slight_smile:

Either use a different version like the D81 disk which has the LOAD program first, so there is no trickery or disk swapping required, or like I said just create a M3U that has


My m3u file for B.A.T. It looks like this:

  • B.A.T. (Side A).g64:LOAD
  • B.A.T. (Side B).g64
  • B.A.T. (Side C).g64
  • B.A.T. (Side D).g64

And I have this error:

Ah you need to use lowercase load since non-shifted are uppercase by default, and those symbols are the shifted ones.


Now works perfect. Thanks a lot for the information.

@sonninnos one more question. Frogger (Sierra On-Line) tap version. To run the game you need a special command:

  • load"frogger",1,1

Is it possible in this case to run the game via autostart by adding the m3u file, or vicerc? I tried different combinations but always basic sees it as load"frogger,1,1"

Tape uses the same method as disk, but slightly different:


I tried No-Intro TAP and it worked with and without this option. It just takes ages to load even with warp. Forcing it to load “frogger” however did not work at all.

That is possible with the same m3u-method.

1 Like

Perhaps it’s a different version. My tap (downloaded from retrocollector.org) only wants to run when we run “frogger” with ,1,1. I made a vicerc file with



m3u Frogger.tap:frogger

and it works without a problem. Many thanks for the help.

I don’t have much experience running VICE but I thought I would give this a shot.

It looks like different source roms can produce very different results.

For the OP I used tape roms and had mixed results.

My first did nothing… my second got to the title screen and then went black… my third (The Firebird Silver version.) got all the way to the game screen but I can’t get the controls to work.


Frogger worked out of the gate with no issues at all.

The only settings I changed were enabling warp (Sound disabled) and a memory expansion board.

Don’t enable memory expansions if you don’t need it. Bunch of games fail to load with extra stuff connected, and extremely small amount can use the extra memory.

1 Like

@Duimon your version of Frogger is from Parker Bros. not Sierra On-Line. They are very similar. Therefore, no additional options are needed when loading the game.