Cannot save new configuration but can overwrite current one

The video shows the behaviour better than any words.

Is this a bug? Is this otherwise something I can fix, and please, how?

Thank you so much for your help!

I noticed that this happens if I load any core. If no core’s loaded, then saving works.

Any hints about why this happens?


Check your config folder, while Retroarch’s customizable configs is nice so you can fine tune from an entire system, content, folder to a single game, it can also be annoying as it works hierarchically, so you can’t save a new config that would conflict with one that is more global and so far it doesn’t say where the conflict is coming from. To make sure this is your case, open your config folder and create a new one, move all your configs there and open the game again, try saving a new config and it will probably work, so you can then track what files are conflicting from the old configs you already have there. The better way, from personal experience, is to make a global config then use overrides for everything else, specific to systems which require fine tuning, this way, conflicts are much less prone to happen. This screenshot illustrates my suggestion above, instead of a dedicated “systemconfig” alongside the retroarch-core-options file, you’ll have config overrides, and core options inside their correspondent folders:

Nothing seems to be wrong there. If you have any Core Overrides saved then you can only save a Global Configuration when no Core is loaded.

Thank you very much for your reply!

I switched (back to) “use global core options file” and behaviour was the same. I then picked up a new empty config directory and it’s apparently… working, thank you!.

Let’s now see if it will withstand the test of time. The previous situation happened after a few days of playing and tweaking.

I definitely feel like something’s could be fixed in how the configuration is dealt with though, or at least to give some very informative error messages other than “failed to save the configuration”. Those could point the user to the right direction.

Thank you.

…it didn’t last much :frowning:

Just changed the touch overlay. The first time I changed it, saved the configuration, it worked. Then I changed my mind, that wasn’t what I wanted, saved again, “failed”:

Why aren’t you using “Save Core Override” since you have a Core loaded?

I did. More specifically:

I changed the overlay (I wanted to change it for the core only) I mistakenly saved the global configuration So I saved the override (it worked) Changed back the overlay to the default one Saved the global configuration again (on purpose. This way I would have reverted the global configuration to the standard overlay, and left the core use its override), and that failed. I’m stuck again.