Can't start RetroArch from CLI

Okay I feel stupid but here it is.

I can start RetroArch using the CLI actually, but only if no “file” argument is passed. So in other words…

retroarch.exe works but retroarch.exe "path\to\game" doesn’t. I’m not saying it doesn’t load the desired game, retroarch doesn’t even start, nothing happens. I’ve tried with different game extensions, and even using -L to select a core, but it doesn’t change anything. If there any file path nothing happens, what the hell does it mean?

Which version are you using? I launch from CLI all the time, so it should work.

1.10.3

Also I’ve tried with cmd and powershell just to be sure, no idea what’s going on.

OK for some reason RetroArch had somehow installed every single core out there all of a sudden. After cleaning it out it works, I don’t know exactly what was going on but I suppose it didn’t know what to do with all that :sweat_smile:

Hmm, yeah, dunno. Having a bunch of cores shouldn’t be a problem, but :man_shrugging: