Can't stop RetroArch from hijacking Guide button with latest version

So I use the xbox ‘Guide’ button for something else, and RetroArch has always tried to hijack it by default. I never complained, because it was fixed easily enough by going to RetroArch\autoconfig\xinput\XInput_Controller_User_1.cfg, opening it, and changing the line input_menu_toggle_btn = “10” to input_menu_toggle_btn = “”.

This no longer works. In fact, I tried deleting the files altogether, and RetroArch still seems to know what all the buttons are. The main config seems to remember the setting, but as soon as you load a core, it sets it to ‘Auto’ and button 10, as if nothing happened.

Any help with this situation would be much appreciated.

I should specify that I am using RocketLauncher, and it loads games via the command line.

Problem doesn’t seem to exist just using the RetroArch user interface.

Ok, because I used the installer, somehow RocketLauncher was launching the RetroArch folder that I had on my desktop for testing purposes.

Everything is working now.

It’d be nice if RetroArch had an option to disable the Guide button as menu though.

Does going into Settings, Input, Hotkey Binds and pressing Delete on Menu toggle work? That clears both the controller and keyboard inputs, so you’d want to press Enter and F1 after clearing it so you can still use the keyboard to get back into the menu.

Unfortunately, no. The ‘Guide’ button has the word ‘Autoconfig’ next to it, and it won’t delete. The only way I’ve had success is going into the autoconfig file and manually editing it.

Which, isn’t too big of a deal, I’m glad that’s at least an option.

But, it would be nice to be able to do it in the GUI. Should be up to the user to decide what they want to do IMO. Always annoyed me that both steam and windows tried to hijack my guide button. Leave my guide button alone, it’s mine, lol

Well, you can turn off Autoconfig under Settings, Input, then manually set all your binds in User 1 Binds. I think there’s a way to create your own custom autoconfig too, but I’ve never looked into it.