Certain MAME titles won't start at all

I’m using latest nighties for Retroarch 20190814, same goes for MAME core (without year) and 0.212 roms and chd sets. With that said, I’m trying to run some games which crashes in the initializing screen. I have checked all needed bios along with their roms or CHD files, but they just won’t start, some games are Raycrisis, Ray Storm and Super Puzzle Bobble, the log says something generic like:

[WARN] [GL debug (Medium, API, Performance)]: Program/shader state performance warning: Vertex shader in program 31 is being recompiled based on GL state.
[ERROR] [GL debug (High, API, Error)]: GL_INVALID_OPERATION error generated. The operation is invalid when the uniform is a matrix.
[WARN] [GL debug (Medium, API, Performance)]: Program/shader state performance warning: Vertex shader in program 1 is being recompiled based on GL state.

A lot of other CHD games, 3D games run fine, like Killer Instinct 1 and 2, Tekken 3 and a lot more, any clue?

What video driver are you using? GL or GLCore? Whichever it is, does it act any differently if you try the other?

I use the GL driver, just tried with GLCore without success with Ray Crisis.

Edit: I forgot to mention, I use Windows 10 x64 1809 and a Nvidia 1660ti with the penultimate drivers (just noticed a new one was released, I’m updating it so I can make sure it’s not GPU related.

Edit 2: The latest Nvidia driver won’t make the games I mentioned above run regardless.

well, I don’t think the MAME core actually uses GL internally at all, so I suspect that GL error originates from RetroArch instead. Can you post the full log of one of the failures?

Sure, thanks for checking! Here is the link:


I just noticed there’s another log generated by RA itself when I turned logging ON, I didn’t know it was there, can be useful:


Have you tried turning off shaders? I’m seeing a lot of GL warnings related to them.


[INFO] Using content: R:\Hyperspin\Roms\MAME\raycris\raycris.chd

It looks like you’re trying to load the CHD file directly…? If so, that’s never going to work.

Yeah, I know it seems incorrect but I actually checked in the romset trying to find the zip file for this game, something like raycrisis.zip, Super Puzzle Bobble also doesn’t have a zip file, like other games, Killer Instinct and many others have. There’s an arcade database where I cross checked and it looks like some games like the above doesn’t have the zip files, for example, check below, COH3002T.ZIP is the only bios MAME requires for Supper Puzzle Bobble, alongside with its folder and CHD inside, same happens for Raycrisis, the site where we can check all MAME related files is: http://adb.arcadeitalia.net

Mame required files

COH3002T.ZIP	4.51 MiB    4,726,800	BIOS	detail
SPUZBOBL /  SPUZBOBL.CHD	14.7 MiB    15,429,728	CHD	-

Apart from that, I also tried Raystorm, which doesn’t have a CHD file (raystorm.zip ), I also generated a new log without any shader this time:



I see these lines in the above log:

1. [libretro WARN] Driver MAME not found -1

2. [libretro ERROR] System not found: MAME

What does that mean, system not found: MAME, is it core related?

I’ve tried many other games ranging from Sega, Namco, Midway, Taito, Data East and many other machines using the very same version for RA, MAME core, etc., they all work fine.

ah, yeah, I see. Is it just games with no actual ROMs that are crashing, then?

Actually, my last log file is from a game called raystorm.zip, which is not a CHD game, it also doesn’t work, MAME gives me a green screen instead, the other CHD games crashes and I need to force close RA, with Ray Storm, MAME makes RA close by itself after the green screen.

It seems to be about games with “Taito Zoom sound system”, as G-Darius v2, raystorm and psyvaria uses that and crash, while some other Zn games with a Yamaha chip work fine.

They are all working on up to date stand-alone with the same rom set.

edit: It was known…

For games like this without a zip file, you can make a dummy file to launch the game if it’s not in the romset. raycrisis also requires tatiogn.zip. So my setup is:

    raycris.zip (empty/dummy file)
    raycris.chd (chd file)
    tatiogn.zip (bios file in romset)

Then you can launch the dummy raycris.zip.

I tried the game in the latest MAME core and it got stuck in the ‘initializing’ screen and wouldn’t proceed. Latest mame also complains about missing a file in coh3002t.zip, which isn’t included in the romset, so I dont think thats an issue (I included the file in my test but it didn’t work anyway). I tried MAME2015 and it worked just fine though. I’m guessing there’s an actual bug in the latest MAME causing it to not work.

1 Like