Citra 3ds japanese font working weird in super robot taisen ux

I’m playing “super robot taisen ux” with citra canary core, The letters look confused, and there are letters that appear as a question mark, I remember that I had this problem in the Citra standalone "but I solved the problem by copying shared_font.bin to the path User / AppData / Roming / Citra

This is the original font form in the Citra standalone emulator

So is it possible to solve this issue by copying the same file to one of the Retroarch folders ?

    1. قائمة العناصر

Yes, you should be able to. You’ll notice when you run Citra-libretro it creates a bunch of folders. Just try dropping that font file into the structure like you would with standalone.

Where is the path where these folders were created? I searched the system folder but I did not find any file named Citra, Do you mean the Citra folder inside the Config folder? I copied the font file there but it didn’t work.

check in the ‘saves’ dir

Aha inside the save folder, I searched all the folders except this one, anyway thank you the problem has been solved, but I was wrong the file responsible for correction isn’t ‘‘shared_font.bin’’ but one of the files inside ‘‘nand’’ folder, and as a kind of return the favor I will upload file that fix this issue for anyony who would like to play this game, it will also work for ‘‘super robot taisen BX’’ https://drive.google.com/drive/folders/1xJxWy3BBM-keJ8XWn6eqpH0Sqelhn6Qs?usp=sharing

1 Like


But still the letters in the citra standalone are clearer than Retro Arch core, I noticed that when I replace the default Rinder settings in the standalone ‘‘qt-config’’ file to these following settings, the letters will be clear.

[Renderer]

use_hw_renderer=true

use_shader_jit=true

use_scaled_resolution=true

use_vsync=false

bg_red=0

bg_green=0

bg_blue=0

toggle_framelimit=false

resolution_factor=0

toggle_autoskip=true

use_hw_renderer\default=true

use_hw_shader\default=true

use_hw_shader=true

shaders_accurate_gs\default=true

shaders_accurate_gs=true

shaders_accurate_mul\default=true

shaders_accurate_mul=false

use_shader_jit\default=true

resolution_factor\default=false

use_vsync\default=true

use_frame_limit\default=true

use_frame_limit=true

frame_limit\default=true

frame_limit=100

bg_red\default=true

bg_green\default=true

bg_blue\default=true

I tried to paste these settings into the opt file for this game since the retroarch citra core doesn’t have
?’‘qt-config’’ file but it didn’t work, So is there another place where these settings can be inserted

In RetroArch have you enabled Settings -> Video -> Bilinear Filtering?

If yes, try to disable it, as it adds a slight blur to the image.

the Bilinear Filtering was enabled, I disabled it and the picture has become less blurry but more pixelated as the picture above. but I found that the clarity of the image in the standalone citra emulator is because the resolution there was x 3, I then changed the Resolutions in the RetrotArch citra core in the game option to X2 and the picture has become exactly the same as that in the citra standalone, But it’s good to know about the Bilinear Filtering feature, I think I will make the filter disabled in all games, so thanl you for your suggestion.