ColecoVision BlueMSX folder and file structure Windows 10


#1

Hey guys,

I have been experimenting a lot, but didn’t succeed; and I find different answers on the net. So I will try it here, after all you are the specialists;-)

I put coleco.rom in /system (where all other bios files are, and all other emulators are running fine), and also tried /system/bios and /system/bluemsx . When I start a game, the screen flickers one time, returns to the RA menu and a message bluemsx.git appears. Apparently, something is wrong or missing.

Could someone give the exact folder and file structure to get ColecoVision games working on RetroArch for Windows?


#2

Is it allowed to ‘bump’ a topic here? I hope it is;-)

I forgot to mention I also tried this, and some variations to it; but to no avail:

Source: https://buildbot.libretro.com/.docs/library/bluemsx/#how-to-install-the-bluemsx-core

"BIOSLink The blueMSX core requires the ‘Databases’ and ‘Machines’ folders from a full installation of blueMSX.

You can download the ‘Databases’ and ‘Machines’ folders from here https://github.com/libretro/blueMSX-libretro/tree/master/system/bluemsx or you can get them from an official full standalone blueMSX emulator installation. (link to blueMSX official website at bottom of page)

Copy the ‘Databases’ and ‘Machines’ Folders to RetroArch’s System directory."

Could someone help out?

Rets


#3

Which download did you use to get the Database and Machine folders?


#4

Hi there,

I got the one mentioned in the posting: https://github.com/libretro/blueMSX-libretro/tree/master/system/bluemsx

Rets


#5

You should have

“System”/Machines “System”/Database

Where “system” is your system folder location. Location determined in Settings->Directory->System/BIOS directory

Once you have that load up a supported colecovision game and enter

quick menu->Options

Change the machine type to Colecovision and save game options file. :slight_smile:


#6

try looking here: [solved] MSX / MSX2 "Failed to load content"


#7

Hi there,

You should have

“System”/Machines “System”/Database

Confirmed, I have this

Where “system” is your system folder location. Location determined in Settings->Directory->System/BIOS directory

Confirmed, I have this. Can you mention which files these 2 folders should content?

Once you have that load up a supported colecovision game and enter

This goes wrong. The screen flashes, returns to RA and “bluemsx.git” appears at the bottom of the screen.

quick menu->Options

Change the machine type to Colecovision and save game options file.

I read about this. From what I understood, this was only obligatory for an older version. The “auto” option should be OK because in a more recent version, autodetect was built-in and proved working.

Hope you help me further! Thanks!

R


#8

try looking here: [solved] MSX / MSX2 “Failed to load content”

Thanks. I did read it, and I’m more confused. Do you think we need to do a full install of bluemsx? I’m asking because https://buildbot.libretro.com/.docs/library/bluemsx/#how-to-install-the-bluemsx-core states we only need the core (and its update) downloaded from RA.

Could you elaborate on this?

R


#9

Perhaps the folders from the blueMSX Github repository are busted. Can you try the folders from an official blueMSX installation instead?

http://bluemsx.msxblue.com/download.html

Get blueMSXv282full.zip


#10

Cool I will check this out and update my core, its been a while.

Cant up images from my phone here but the databases folder has a handful of files and the machines folder has maybe 100 other folders in


#11

Going through the Databases and Machines folders in blueMSX’s repository, I’m noticing it’s missing bios files from blueMSX’s full installation.

Strange.

I would fix this but idk If it’s allowed.


#12

This did the trick. Thanks a lot!

I think 2 things are up for improvement:

  1. The documentation: https://buildbot.libretro.com/.docs/library/bluemsx/#how-to-install-the-bluemsx-core could be a bit more precise about which files from which sources need to be put where;
  2. The RA/LibRetro distribution of the BlueMSX core. One of the great things about RA is that almost every emu runs at the push of a button, so it’s a bit awkward that for BlueMSX a bunch of files from another source need to be downloaded and put in place. But maybe this is a licensing issue, IDK.

Another thanks. I’m off playing DK!

Da R


#13

I updated the documentation.

https://docs.libretro.com/library/bluemsx/#bios

is this better?


#14

No, it’s not “better”. It’s WAY, MUCH better! :wink:


#15

Hi guys.

Sorry to bump the topic after so long but as it’s not set to solved I believe it’s the right place to post. After a few days lost trying everything I could find about running ColecoVision in RetroArch (1.7.6) using the latest blueMSX Core in Windows 10, I was left with no option besides coming back here to the most complete topic available.

Followed the whole procedure with all variations I could think of, such as:

  • placing the “Databases” and “Machines” folders within “system” directly, “system\bluemsx”, “system\bluemsxv282full” (after making sure I had all bios and files confirmed donwloaded from blueMSX website full version zipped);
  • tried editing parameter bluemsx_msxtype from retroarch-core-options.cfg file manually (although not mentioned here and obsolete as the “auto” option should do the job;
  • tried different romsets and zipped and unzipped (.col) files;
  • tried to find the place after launching the core to select ColecoVision as seen in many forums (what I was not able to as the greenish screen I get has nothing besides generic RetroArch options);
  • tried to find the quick menu -> options after loading the Core, again not being able to find any option for the core;
  • etc…

Some additional info: Retroarch is running normally for all my other systems and the Roms I have work normally in my Retropie that also uses Retroarch.

In sum, going back to the problem, I get the message “failed to load content” after selecting any Rom and pointing to blueMSX core in RA.

Any idea or suggestion on how to find what’s wrong?

Many thanks in advance for all the great work and any help is really appreciated!

LOG: https://pastebin.com/raw/8ULmuXaK


#16

I dont have the setup you have but what I just did on my android S7phone. With a recent (within 4weeks) 1.7.6 nightly

Downloaded bluemsx core Followed link on docs page to download bluemsx full zip file Extracted to my “system” folder Browsed to the game Donkey Kong (USA, Europe).col

Game started all ok. Hit a couple of buttons to get into gameplay.

  1. Maybe check you have the correct download zip file from bluemsx website

  2. Check your game file worka ok somewhere else or try other games with this core.

  3. Open your retroarxh-core-options.cfg file and remove all the “bluemsx” settings lines to start fresh

Good luck


#17

Thanks for checking! I reviewed and did everything once again, just in case, but still no luck.

If you guys have any idea on how to pinpoint what’s wrong it would be really appreciated. Thanks again!