Compiling lakka error


#1

Does this make any sense to anyone?? I am trying to compile generix 64 bit lakka on debian.

[email protected]:~$ su Password: [email protected]:/home/maniacs# cd Lakka-LibreELEC [email protected]:/home/maniacs/Lakka-LibreELEC# DISTRO=Lakka PROJECT=Generic ARCH=x86_64 make image ./scripts/image mkimage

================================================================================= Configuration for Lakka (community)

Buildoptions:

  • CPU (ARCH): x86-64 (x86_64)
  • FLOAT:
  • FPU:
  • SIMD support: yes
  • LTO (Link Time Optimization) support: yes
  • GOLD (Google Linker) Support: yes
  • LLVM support: yes

Graphic configuration:

  • OpenGL (GLX) support (provider): yes (mesa)
  • OpenGLES support (provider): no (no)
  • Vulkan support (provider): no ()
  • uvesafb support: yes

Hardware decoder configuration:

  • Kodi Player driver: default
  • VAAPI Support: yes
  • VDPAU Support: yes

Input device configuration:

  • Remote support: no
  • ATV Remote support: no
  • CEC Adapter support: yes
  • Kodi Joystick support: yes

Misc. hardware configuration:

  • ALSA support: yes
  • Pulseaudio support: no
  • Bluetooth support: yes
  • Include driver: bcm_sta
  • Include driver: media_build
  • Include driver: intel_nuc_led
  • Include driver: applespi
  • Include firmware: misc-firmware
  • Include firmware: wlan-firmware
  • Include firmware: dvb-firmware
  • Include firmware: iwlwifi-firmware

Network service configuration:

  • Avahi (Zeroconf) support: yes
  • NFS mounting support: yes
  • SAMBA mounting support: yes
  • SAMBA server support: yes
  • SFTP server support: yes
  • OpenVPN support: yes

OS configuration:

  • OEM Support: yes
  • Default ROOT Password: root
  • Bootloader: syslinux
  • UDevil support: yes
  • Installer support: yes

Misc. Filesystems:

  • Swap Support: no
  • exFAT Support (via Fuse): yes
  • NTFS Support (via Fuse): yes
  • Install HFS Tools: yes

Kodi configuration:

  • Kodi version: no
  • Kodi nonfree support: yes
  • Kodi Blu-Ray support: yes
    • Bluray BD+ support: yes
    • Bluray AACS support: yes
  • Kodi DVDCSS support: yes
  • Kodi Airplay support: yes
  • Kodi Airtunes support: yes
  • Kodi NFS support: yes
  • Kodi MySQL support: yes
  • Kodi Optical Drive support: yes
  • Kodi SAMBA client support: yes
  • Kodi SSH client support: yes
  • Kodi UPNP support: yes
  • Kodi Webserver support: yes
  • Include Skin: Confluence
  • Default Skin: Confluence
  • Include extra fonts: yes

================================================================================= End Configuration for Lakka

INSTALL libc (target) INSTALL toolchain (target) INSTALL configtools (host) INSTALL make (host) INSTALL xz (host) INSTALL sed (host) INSTALL pkg-config (host) INSTALL autoconf (host) INSTALL automake (host) INSTALL libtool (host) INSTALL intltool (host) INSTALL autoconf-archive (host) INSTALL gcc (host) INSTALL bison (host) INSTALL flex (host) INSTALL cmake (host) INSTALL yasm (host) INSTALL glibc (target) INSTALL ccache (host) INSTALL autotools (host) INSTALL linux (host) INSTALL gcc (bootstrap) INSTALL tz (target) INSTALL gcc (target) INSTALL linux (target) INSTALL cpio (host) INSTALL kmod (host) INSTALL pciutils (target) INSTALL kmod (target) INSTALL systemd (target) INSTALL libcap (target) INSTALL util-linux (target) INSTALL wireless-regdb (target) INSTALL keyutils (target) INSTALL intel-ucode (host) INSTALL kernel-firmware (target) INSTALL linux-drivers (target) INSTALL bcm_sta (target) INSTALL media_build (target) INSTALL intel_nuc_led (target) INSTALL applespi (target) INSTALL linux-firmware (target) INSTALL misc-firmware (target) INSTALL wlan-firmware (target) INSTALL dvb-firmware (target) INSTALL iwlwifi-firmware (target) BUILD openssl (target) Configuring for linux-x86_64 no-ec2m [option] OPENSSL_NO_EC2M (skip dir) no-gmp [option] OPENSSL_NO_GMP (skip dir) no-jpake [experimental] OPENSSL_NO_JPAKE (skip dir) no-krb5 [krb5-flavor not specified] OPENSSL_NO_KRB5 no-libunbound [experimental] OPENSSL_NO_LIBUNBOUND (skip dir) no-md2 [option] OPENSSL_NO_MD2 (skip dir) no-rc5 [option] OPENSSL_NO_RC5 (skip dir) no-rfc3779 [option] OPENSSL_NO_RFC3779 (skip dir) no-sctp [option] OPENSSL_NO_SCTP (skip dir) no-ssl-trace [option] OPENSSL_NO_SSL_TRACE (skip dir) no-ssl2 [option] OPENSSL_NO_SSL2 (skip dir) no-ssl3 [option] OPENSSL_NO_SSL3 (skip dir) no-static-engine [option]
no-store [experimental] OPENSSL_NO_STORE (skip dir) no-unit-test [option] OPENSSL_NO_UNIT_TEST (skip dir) no-weak-ssl-ciphers [option] OPENSSL_NO_WEAK_SSL_CIPHERS (skip dir) no-zlib [option]
no-zlib-dynamic [option]
IsMK1MF=0 CC =/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/toolchain/bin/x86_64-libreelec-linux-gnu-gcc CFLAG =-fPIC -DOPENSSL_PIC -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -march=x86-64 -m64 -fomit-frame-pointer -Wall -pipe -O2 -flto -ffat-lto-objects -mmmx -msse -msse2 -mfpmath=sse -march=x86-64 -m64 -fuse-ld=gold -fuse-linker-plugin -flto -m64 -DL_ENDIAN -O3 -Wall -DOPENSSL_IA32_SSE2 -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_MONT5 -DOPENSSL_BN_ASM_GF2m -DRC4_ASM -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM -DVPAES_ASM -DBSAES_ASM -DWHIRLPOOL_ASM -DGHASH_ASM -DECP_NISTZ256_ASM EX_LIBS =-Wl,–as-needed -ldl CPUID_OBJ =x86_64cpuid.o BN_ASM =x86_64-gcc.o x86_64-mont.o x86_64-mont5.o x86_64-gf2m.o rsaz_exp.o rsaz-x86_64.o rsaz-avx2.o EC_ASM =ecp_nistz256.o ecp_nistz256-x86_64.o

a BUUUNCH of stuff in between (too many characters for post)

make[2]: Entering directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu/apps’ make[2]: warning: jobserver unavailable: using -j1. Add ‘+’ to parent make rule. installing openssl installing CA.sh installing CA.pl installing tsget make[2]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu/apps’ making install in test… make[2]: Entering directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu/test’ make[2]: warning: jobserver unavailable: using -j1. Add ‘+’ to parent make rule. make[2]: Nothing to be done for ‘install’. make[2]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu/test’ making install in tools… make[2]: Entering directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu/tools’ make[2]: warning: jobserver unavailable: using -j1. Add ‘+’ to parent make rule. make[2]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu/tools’

installing libcrypto.a installing libssl.a installing libcrypto.so.1.0.0

installing libssl.so.1.0.0 Segmentation fault

make[1]: *** [Makefile:552: install_sw] Error 139

make[1]: Leaving directory '/home/maniacs/Lakka-LibreELEC/build.Lakka-

Generic.x86_64-2.2-devel/openssl-1.0.2o/.x86_64-libreelec-linux-gnu’

Makefile:29: recipe for target ‘image’ failed

make: *** [image] Error 2 [email protected]:/home/maniacs/Lakka-LibreELEC#


#2

Looks like it’s choking on install libssl. Have you tried installing it separately?


#3

To be honest i don’t know what that means. I been typing in errors that say “perl lib jay” or something error and have been doing “apt-get install perl (etc…)” For any error and it had been getting past the errors.

But now I’m not sure what the scheme is. I also think that it has something to do with “packages” on build tools. So if i had the right OS with the correct setup i believe it will breeze thru…

Have tried on ubuntu. Started with aptget upgrade/update etc. And all sorts of errors with compiling…

What is the best linux os to compile lakka?

Ubuntu and debian giving me errors. But to be fair i just got into command line… Like just figured out “cd (etc)” to get into folder and -r to delete folder… Total noob :pensive:


#4

Also thanks Hunterk i don’t know if you troll the forums but i appreciate the ANY response pretty quickly.

Doing Gods work bro. Thanks


#5

I’ve compiled it via Ubuntu before, but that was quite a while ago. By installing libssl separately, I meant:

sudo apt-get install libssl1.0.0

that will go ahead and it on your system and hopefully stop the segfault that’s happening when it installs it automatically.


#6

“libssl1.0.0 has no installation candidate”


#7

I’m on Ubuntu 18.04 LTS. If you’re using something else, do:

apt-cache search libssl

and it will list a bunch of packages. Just install whichever one is available, though if it requires 1.0.0 for some reason, you may still have issues.


#8

“Warning jobserver unavailable” … Install sw error 139…

I will pick it up in the morning for sort.

So maybe it got past the last error… Image error 2 again recipe for target image failed.

Segmentation fault…

Installing lincrypto.a Libssl.a Lobssl.so.1.0.0

Brutal