Configuring gamecube L R Shoulder buttons to keyboard input

When playing zelda twilight princess for gamecube all the buttons I map to keyboard work except L R shoulder buttons. I already tried changing input drivers under options but nothing works. I also tried the latest nightly builds off build-bot to no avail. Could someone please help me to map L R analog and digital to keyboard!

Sorry to revive this topic but i don’t see the button to start a new one.

I have a problem with GameCube games, it works well all the buttons in the menu and all working well, arrow keys…etc but with RetroArch on steam it doesn’t recognize the arrow keys while in game, just the action buttons. I disabled steam input still the same problem?

How can i make the keyboard movement keys working?

If the game only accepts analog movement, the arrow keys won’t work by default, as they are digital dpad inputs. You would need to map the analogs to somewhere else on your keyboard (I usually use the numpad).

Yes that was it, managed to work it out, thanks a lot!

1 Like