Controller Mapping


#1

I recently switched over most of my systems to RA and I am really liking it. I am trying to map my buttons to specific ways. I notice that within the Input settings RA gives you the SNES button layout, but not the current systems button layout. For instance on Sega Saturn, I see that there is XYAB, but there is nothing showing the controller that I want to map. Since Saturn was ABC I want to map them to X=A A=B B=C on my 360 controller. Is there something I have missed? Am I over thinking this?

Bold = 360 buttons Thank you.


#2

That’s so odd… it normally does rename the inputs to the proper setting - but I just checked my input options and none of the cores are showing the right buttons now.

I’m using 1.7.1 are you on the same newest stable?


#3

Yes I am on 1.7.1. Just downloaded it the other night.


#4

Anyone else having this issue? I would really like to map my buttons to the setup I had prior to switching them all over to RA.


#5

It’s showing the buttons properly for me under input AND controls (this is a snes pad)


#6

Also with a DS3


#7

Aaaaaand XBOX360


#8

@OP did you config your gamepad manually? if you did they won’t have labels, but in windows at least with autoconf everything is working nicely out of the box


#9

I think we are miscommunicating - and correct me if I’m wrong @mccorkled - but we are talking about the left-side of that input screen, not the right-side.

Where it would previously, if you loaded up the Saturn or Genesis cores for example, it would show C instead of R or Z instead of L etc etc.


#10

Left Side of Controls always shows the controls from the core. Unless they aren’t defined that is.


#11

But that’s what I’m saying - it’s not doing that

(I also checked this on XMB, just to be sure)

Unti2tled


#12

Not sure what’s up with your setup but


#13

I just did a fresh go of the latest nightly build and it’s still not pulling up. I remember there ‘used’ to be an option in Settings>Input that was called something like “Hide Input Descriptors” or “labels” or something like that. I’m not seeing it anymore though.

Could it be related to such a setting?


#14

I am trying to configure some system manually to match my setup. @SkyHighGam3r is exactly right with the issue I am having. I don’t want it to work “out of the box”. Certain systems like Game Boy use A and B for jump/shoot, and it is much more comfortable to use X and A.


#15

Any more info on this?


#16

Hi @mccorkled. This thread is rather confusing.

Based on your first post and your Mar 6 post, it seems that what you are referring to is the core input remapping function. This is a nice reference:


#18

If you temporarily move your retroarch.cfg to another directory (i.e., to get a fresh config), do you still not see them?


#19

I have seen this before but they used to display (not the images) within the core settings when mapping buttons.